lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-20-2013, 12:44 PM   #1
Not Yet Wild
 
Join Date: Feb 2013
Posts: 2
Default no lights horn no electric

cart runs fine but I have no accessories lights horn ect. cart charges and runs fine. 2009 club car rebuilt just bought few months ago no help from dealer.
KRAMERRAYRAY31 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-20-2013, 04:38 PM   #2
Getting Wild
Club Car
 
Join Date: Jun 2013
Location: Sugar Land, TX
Posts: 126
Default

Sounds like a fuse. Look for blue wire with inline fuse.
smackdaddy66 is offline   Reply With Quote
Unread 11-20-2013, 04:48 PM   #3
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: no lights horn no electric

. . . first to BGW . . . do you know if you have a voltage reducer running your lights/accessories? . . . look for inline fuse between reducer and battery positive connection . . . if you have a fuse block that is connected between reducer and lights/accessories, check fuses there . . . otherwise, check for inline fuse between positive connection and lights, probably coming off your number 1 or number 2 battery, depending on whether it is running 8v or 16v for lights/accessories . . .
Stevegrmich is offline   Reply With Quote
Unread 11-20-2013, 04:54 PM   #4
Not Yet Wild
 
Join Date: Feb 2013
Posts: 2
Default Re: no lights horn no electric

Tx would one fuse cause all electrical parts to not work
KRAMERRAYRAY31 is offline   Reply With Quote
Unread 11-20-2013, 05:13 PM   #5
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,895
Default Re: no lights horn no electric

Quote:
Originally Posted by KRAMERRAYRAY31 View Post
Tx would one fuse cause all electrical parts to not work
Yes if it's all on the same circuit.
jakesnake27 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
No lights,signals,horn Electric Club Car
No lights or horn Electric EZGO
Need HELP. Only lights and horn works. Electric EZGO
No lights or horn Electric EZGO
Lights and Horn question Electric Club Car


All times are GMT -5. The time now is 07:11 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.