lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars

Post New Thread  Reply
Thread Tools Display Modes
Unread 03-30-2014, 07:33 PM   #11
Not Yet Wild
Club Car
Join Date: May 2008
Posts: 15
Default Re: 2003 DS Series Speed Issue

I haven't been home much to work on this, but I want to bump it with some new information to see if anyone can help.

I had a stock CC that needed some batteries, so I bought a new set for this cart, and swapped the old ones into the stock cart. So now, batteries are not going to be an issue.

I apologize for my ignorance, but some of the original data was incorrect. Now that I have taken everything apart, I know that I have a Logisystems 700 amp controller. Because this is a 5k-0 controller, will it now matter that the MCOR is only delivering 1100 ohms? ScottyB gave someone the Logisystems tech support number back in '09 to check into this, but I never saw any resolution. I know they are out of business now.

As another note, whoever installed this 700 amp controller, left STOCK wiring in place (this will be upgraded soon). This shouldn't effect the top speed, but I was surprised they haven't melted. They don't seem to be getting hot when driving, and the acceleration is not what I would expect from 700 amps, so I feel like the controller is never delivering anywhere near 700 amps.

Thanks again for any help, I am lost at this point, and don't know what to check next. I am lifting the cart, and am going to put 22+ inch tires on it, so I would like to get the necessary torque.
wbbragg is offline   Reply With Quote
Alt Today

Golf car forum Sponsored Links

This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
Unread 04-14-2014, 09:44 AM   #12
Crazy Buggy Wild !!
InVision's Avatar
Club Car
Join Date: Mar 2014
Location: Destin, Florida
Posts: 524
Default Re: 2003 DS Series Speed Issue

I have a PQ motor and a stock curtis controller 225 amp. My MCOR is reading 9.65K down to 1168 ohms. If Tahoe says it is ok I believe it is for sure. Anyway I have 22.5 inch tires and new t875 batteries with 2 gauge wire. I am getting 20-22 mph top speed on level ground. I picked up some more torque with wires but no top end. I guess what scares me is I am considering a 700 amp controller. Scotty said I would have to turn it down to 500 or so to work with my motor.

I will keep you in the loop.


My motor looks like this...
Attached Images
File Type: jpg IMG_3840.JPG (703.6 KB, 0 views)
File Type: jpg IMG_3841.JPG (778.8 KB, 0 views)
InVision is offline   Reply With Quote

series speed bandit mcor
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car

Thread Tools
Display Modes

Similar Threads
Thread Forum
2003 TXT Series upgrade questions Electric EZGO
2003 cc DS series solenoid not firing Electric Club Car
2003 EZGO 36V TXT Series Cart Electric EZGO
2003 EZGO TXT Series 36V New Upgrades Electric EZGO
2003 txt clutch issue?? Gas EZGO

All times are GMT -5. The time now is 02:35 AM.

Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.