lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-28-2013, 09:48 AM   #1
Not Yet Wild
 
Join Date: Nov 2013
Posts: 7
Default 04 precedent studdering.....

Been away for awhile and seem to have lost access under my old handle "BRS". Anyway, need some help from my old buddies as I am a little rusty. My 04 precedent test 52 volts, non load, however when gas is pressed is starts to go and studders. I couldn't remember if this may be the solenoid or mcor. My son was apparently mashing the pedal repeatedly and then "pop". Help an old newbie.....please. Thanks in advance.

Happy Thanksgiving!!!!
ccpro is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-28-2013, 10:00 AM   #2
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: 04 precedent studdering.....

Quote:
Originally Posted by ccpro View Post
Been away for awhile and seem to have lost access under my old handle "BRS". Anyway, need some help from my old buddies as I am a little rusty. My 04 precedent test 52 volts, non load, however when gas is pressed is starts to go and studders. I couldn't remember if this may be the solenoid or mcor. My son was apparently mashing the pedal repeatedly and then "pop". Help an old newbie.....please. Thanks in advance.

. . . welcome back to BGW . . . . even though the batteries are testing at 52v with no load, you may have a bad battery(s) with bad cell(s) that are failing under load . . . load test batteries and check SG of all cells to rule out (or in) a battery(s) issue first . . .
Stevegrmich is offline   Reply With Quote
Unread 11-28-2013, 11:00 AM   #3
Not Yet Wild
 
Join Date: Nov 2013
Posts: 7
Default Re: 04 precedent studdering.....

Thanks Steve,

Batts test same under load??? And are all testing 12.7 or better alone. I can hear the solendoid engage and cart wants to move but can't. I have mcor/potentiometer exposed....how can I test continuity? I think because my son was stomping on the pedal over and over he may have fried it? They heard a loud pop? I did not see an inline fuse off the mcor.
Thanks.
ccpro is offline   Reply With Quote
Unread 12-03-2013, 03:24 PM   #4
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,883
Default Re: 04 precedent studdering.....

Quote:
Originally Posted by ccpro View Post
Been away for awhile and seem to have lost access under my old handle "BRS". Anyway, need some help from my old buddies as I am a little rusty. My 04 precedent test 52 volts, non load, however when gas is pressed is starts to go and studders. I couldn't remember if this may be the solenoid or mcor. My son was apparently mashing the pedal repeatedly and then "pop". Help an old newbie.....please. Thanks in advance.

Happy Thanksgiving!!!!
Did you get BRS back? I thought I saw you post the other day...
jakesnake27 is offline   Reply With Quote
Unread 12-07-2013, 07:40 AM   #5
Master BS'r
 
BRS's Avatar
Club Car
 
Join Date: Jul 2007
Location: S. Florida
Posts: 1,819
Default Re: 04 precedent studdering.....

Quote:
Originally Posted by jakesnake27 View Post
Did you get BRS back? I thought I saw you post the other day...
yes, thanks....I'm not sure what I was doing wrong.
BRS is offline   Reply With Quote
Unread 12-07-2013, 07:44 AM   #6
Master BS'r
 
BRS's Avatar
Club Car
 
Join Date: Jul 2007
Location: S. Florida
Posts: 1,819
Default Re: 04 precedent studdering.....

I guess I'm allowed to hijack this thread..lol. Going to load up the cart, spoke to a tech at a cc dealer, wow clueless!!!! He said there is no way of determining if it's the mcor or controller other than replacing the part(mcor) or sending out the controller. If it's the controller, I'm going to upgrade anyway just wish I knew what it was before I load my cart up and pay for a service call!!!!
BRS is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Studdering Electric Club Car
85 g1 jumping and studdering Gas Yamaha
Studdering / Jumpy Throttle Electric Club Car
07 Precedent or DS Electric Club Car
Slow studdering operation Electric EZGO


All times are GMT -5. The time now is 09:16 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.