lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-27-2013, 08:36 PM   #1
Not Yet Wild
Club Car
 
Join Date: Dec 2013
Posts: 2
Default Put new batteries and cart is dead

I just put two new 12v batteries in my 2004 Precedent. I moved two relatively new batteries that were in the front position on both sides to the back position. I placed my two new batteries in the two front positions. I didn't realize I was suppose to have the tow/run in tow. So I replaced the batteries with the switch in run position.

I've reconnected the batteries and the cart is dead. Charger won't kick on. Any advice would be appreciated.
jnashert@cox.net is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-27-2013, 09:22 PM   #2
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,976
Default Re: Put new batteries and cart is dead

You very well could have blown the controller. Did you get sparks when changed the batteries. Also you could have not got the cables correct. Regardless put cart I tow anytime you are doing anything around the batteries.
mrgolf is offline   Reply With Quote
Unread 12-27-2013, 10:15 PM   #3
Not Yet Wild
Club Car
 
Join Date: Dec 2013
Posts: 2
Default Re: Put new batteries and cart is dead

No sparks at all. I'll double check the wiring.
jnashert@cox.net is offline   Reply With Quote
Unread 12-27-2013, 10:33 PM   #4
Gone Wild
 
Great white north's Avatar
E-Z-GO
 
Join Date: Nov 2012
Location: Ontario , Canada
Posts: 608
Default Re: Put new batteries and cart is dead

Check your wiring but more then likely controller is pooched
Great white north is offline   Reply With Quote
Unread 12-27-2013, 11:02 PM   #5
Not Yet Wild
 
Rockstar007's Avatar
 
Join Date: Dec 2013
Posts: 6
Default Re: Put new batteries and cart is dead

could the new batterys be to low of charge to kick on the charger?
doesn't the total pack charge need to be 36v or so to kick it on?
Can you check your battery pack voltage?
Rockstar007 is offline   Reply With Quote
Unread 12-28-2013, 01:12 PM   #6
Gone Wild
 
miker's Avatar
Mixed Breed
 
Join Date: Jul 2008
Location: mass
Posts: 477
Default Re: Put new batteries and cart is dead

im with great white club cars are very sensitive you look funny at the controller they pop
miker is offline   Reply With Quote
Reply

Tags
replace batteries
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Cart Shutters as if Batteries are dead Electric EZGO
Replaced batteries, now cart is dead. Electric EZGO
Dead Batteries/Cart will not go Electric Club Car
EZGO electric cart dead after new batteries Electric EZGO
Dead Batteries Help please. Electric EZGO


All times are GMT -5. The time now is 03:34 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.