lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-27-2013, 09:08 PM   #1
Not Yet Wild
 
Join Date: Dec 2013
Location: Mesa, AZ
Posts: 19
Default losing voltage on lighting circuit

I have a 98 Club Car 48v that I'm trying get the factory lights to work on. This cart has the horn and lights but neither work when I got it. I have adopted this cart at work and when I got it the cart was sitting on it's side behind a pile of junk in the shop. So far I have replaced all the tires, batteries and am now attempting to get the lights to work. It does have a 16v to 12v reducer and I do get 12 volts at the light switch but as soon as I pull out the light switch I lose all the voltage at the light switch and no lights will work, if I take out the bulbs from all the sockets and pull out the light switch I do get 12 volts to the light sockets. I am stumped at the moment, any help would be appreciated.
KSever is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
How much is too much-lighting? Gas Yamaha
LED Lighting Design Center
Losing R.P.M Gas Yamaha
2001 villager 48v lighting circuit Electric Club Car


All times are GMT -5. The time now is 02:09 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.