lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-17-2014, 04:55 PM   #1
Not Yet Wild
 
Join Date: May 2013
Posts: 3
Default Power to motor w/o key?

A few weeks ago I moved the cart (95 CC DS) around the garage then locked the brake, turned it off and removed key. F&R shifter left in Forward position. A little while later I smelled burning electrical and finally realized a lot of heat coming off the motor and it was very hot to the touch. I released the brake and it surged forward till I hit something (6 inches..). I moved the shifter into neutral and ended up removing a battery connection to cut the power. No key, in the off position and it still had power to the motor.

I'm new to carts so I don't even know where to start. Any thoughts what to check first?
Thanks!
3HourTour is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-17-2014, 05:40 PM   #2
Getting Wild
Club Car
 
Join Date: Mar 2013
Location: Syracuse, NY
Posts: 107
Default Re: Power to motor w/o key?

I had a very similar issue. In my case I inverted the connections to the key switch. Not sure if that helps at all but ... I tried =)
Shawn8202 is offline   Reply With Quote
Unread 01-18-2014, 12:01 AM   #3
Not Yet Wild
 
Join Date: May 2013
Posts: 3
Default Re: Power to motor w/o key?

Its been working fine since I purchased it 6 months ago and just started acting weird suddenly. Not sure where to start so I guess I'll check this first. Thanks!
3HourTour is offline   Reply With Quote
Unread 01-18-2014, 12:40 PM   #4
Gone Wild
 
rose88's Avatar
Club Car
 
Join Date: Apr 2010
Location: West Tennessee
Posts: 1,036
Default Re: Power to motor w/o key?

Sounds like you are getting a signal saying key is on when its not. I would check voltage starting at key switch back to battery pack.
rose88 is offline   Reply With Quote
Unread 01-18-2014, 03:27 PM   #5
Gone Wild
Club Car
 
Join Date: Feb 2012
Location: Indio, CA The Desert!
Posts: 1,177
Default Re: Power to motor w/o key?

I had a similar type issue, ( twice) the cart would run without a key being on.

What my problem turned out to be , was the solenoid. One time the solenoid was welded close. The other, the resistor was lying against the small post of the solenoid, passing voltage to the post.
smokey tennis shoe is offline   Reply With Quote
Unread 01-18-2014, 03:41 PM   #6
Gone Wild
Yamaha
 
Join Date: May 2012
Location: Rio Verde, Az
Posts: 2,681
Default Re: Power to motor w/o key?

Sounds like a stuck solenoid.
Volt_Ampere is offline   Reply With Quote
Unread 01-18-2014, 09:38 PM   #7
Not Yet Wild
 
Join Date: May 2013
Posts: 3
Default Re: Power to motor w/o key?

Thanks all for the suggestions. I'll check these out tomorrow.
3HourTour is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
motor power? Electric golf carts
no power to motor? Electric EZGO
97 CC low power, motor controller? Electric Club Car
how do i check my motor for power Electric EZGO
no power to motor Electric Yamaha


All times are GMT -5. The time now is 09:47 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.