lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-05-2008, 06:53 PM   #1
Not Yet Wild
Club Car
 
Join Date: Oct 2008
Location: Indiana
Posts: 6
Default 95 CC Missing hi speed

New to forum , need help finding hi speed on 95 cc. 1st gear works forward and reverse but shuts off when put to floor, both forward and reverse.....Everybody else seems to lose low speed.......Any help out there.......
keithv153 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-05-2008, 06:57 PM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 95 CC Missing hi speed

what voltage?......................................
shadowman is offline   Reply With Quote
Unread 10-05-2008, 07:36 PM   #3
Not Yet Wild
Club Car
 
Join Date: Oct 2008
Location: Indiana
Posts: 6
Default Re: 95 CC Missing hi speed

48v
keithv153 is offline   Reply With Quote
Unread 10-05-2008, 07:45 PM   #4
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: 95 CC Missing hi speed

Welcome to the forum keithv153...............
rusty is offline   Reply With Quote
Unread 10-05-2008, 07:51 PM   #5
Not Yet Wild
Club Car
 
Join Date: Oct 2008
Location: Indiana
Posts: 6
Default Re: 95 CC Missing hi speed

thanks
keithv153 is offline   Reply With Quote
Unread 10-05-2008, 10:17 PM   #6
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 95 CC Missing hi speed

does it have the V-glide? black pie shaped box down in by the drivers side batteries......................................
shadowman is offline   Reply With Quote
Unread 10-05-2008, 10:28 PM   #7
**** guzzler
Club Car
 
Join Date: Dec 2006
Location: S. E. Mich.
Posts: 730
Default Re: 95 CC Missing hi speed

I would check the vglide if you have one, see if the arm is sweeping correctly.
JRay is offline   Reply With Quote
Unread 10-06-2008, 06:24 PM   #8
Not Yet Wild
Club Car
 
Join Date: Oct 2008
Location: Indiana
Posts: 6
Default Re: 95 CC Missing hi speed

no vglide just the f/n/r switch....
keithv153 is offline   Reply With Quote
Unread 10-06-2008, 06:36 PM   #9
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 95 CC Missing hi speed

either as a V-glide or a pot box........pot box is under cart mounted to frame drivers side...it has to have a speed system so its one or the other......................
shadowman is offline   Reply With Quote
Unread 10-06-2008, 06:43 PM   #10
Not Yet Wild
Club Car
 
Join Date: Oct 2008
Location: Indiana
Posts: 6
Default Re: 95 CC Missing hi speed

it's has the pedal mount underneath
keithv153 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Update On Missing 1st Speed Electric golf carts
missing 1st speed Electric Club Car
Speed and rpm Gas Club Car
speed Gas EZGO


All times are GMT -5. The time now is 02:46 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.