lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-30-2014, 10:23 PM   #1
Not Yet Wild
 
Join Date: Aug 2009
Posts: 18
Default Installed light kit Now it won't move!

Hi,
I have an 2009 Club Car Precedent. I installed a light kit head, tail and wiring harness. After installing kit, now my c art won't move! I have 50 volts on the pack and key switch. an alarm sounds when I hook up the ground wire on the light kit harness. Any ideas ? Thanks alot!!
srv010 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-30-2014, 11:00 PM   #2
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,978
Default Re: Installed light kit Now it won't move!

Did you put cart in tow when you were working on it? Also if you have not smoked something unhook what you have done and see what you get then.
mrgolf is offline   Reply With Quote
Unread 01-30-2014, 11:16 PM   #3
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,889
Default Re: Installed light kit Now it won't move!

I agree, I hope you flipped to Tow while wiring the lights!
So the reverse buzzer goes off when you hook up the ground of the light kit?
Also, you didn't ground to the frame did you?
jakesnake27 is offline   Reply With Quote
Unread 01-31-2014, 07:02 PM   #4
Not Yet Wild
 
Join Date: Aug 2009
Posts: 18
Default Re: Installed light kit Now it won't move!

Yes I put in Tow mode before working on it, I ground it to a wire set up for it. I plan to unwire my lights tomorrow morning. Hope it moves then. will let you know how it went.
Thanks for the HELP!
srv010 is offline   Reply With Quote
Unread 02-01-2014, 07:30 PM   #5
Not Yet Wild
 
Join Date: Aug 2009
Posts: 18
Default Re: Installed light kit Now it won't move!

I unhooked the wiring harness that came with the lightkit. Hooked up club cvar harness and now it moves. I wired up lights only frrom light kit and now lighjts work too. Thanks to all for the help!!
srv010 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Installed sport bumper with light bar... Gas Yamaha
1996 Series DS 48V won't move on ground, wheels barely move on jacks Electric Club Car
Anyone ever installed a brake light switch? Gas Yamaha
Precedent Light Kit Installation Tail Light Question Electric Club Car
G9 Backup Light Installed Gas Yamaha


All times are GMT -5. The time now is 02:20 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.