lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-02-2014, 09:38 AM   #1
Master BS'r
 
BRS's Avatar
Club Car
 
Join Date: Jul 2007
Location: S. Florida
Posts: 1,819
Default Got it wrong!!!

Well I thought I had done enough research to arrive at the correct diagnosis for my 05 CC 48v Precedent...but no. Cart simply stopped reacting to the gas pedal. Tested all continuity, narrowed it down to the controller or the pot.box or whatever we're calling it. Anyway, replaced controller, all connections good, batt. voltage good, solenoid good....and nothing! I'm suprised I havent' been able to find more diagnostic info on this problem...it seems no one really know and just makes and educated guess. Now that I've eliminated one part, I guess I'll try the potentiometer? However, I really believed it had to be that controller based on the symptoms. Cart takes charge, good batts, feels like it's going to move and nothing. Any enlightenment would be awesome. Thanks in advance.
BRS is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-02-2014, 10:31 AM   #2
Master BS'r
 
BRS's Avatar
Club Car
 
Join Date: Jul 2007
Location: S. Florida
Posts: 1,819
Default Re: Got it wrong!!!

Update, I have the wheels off the ground and they are trying to move, very slowy...they seem bound. I hear a very light vibration when the gas pedal is pressed but cannot isolate the vibration. Is does not feel like to motor, the axel, the controller or anything I can put my hands on...it's weird, coming from under the seat but I can't find the source?
BRS is offline   Reply With Quote
Unread 02-02-2014, 02:05 PM   #3
Ban Puppy Mills & Stores!
 
scubabud's Avatar
Club Car
 
Join Date: Dec 2008
Location: SE Florida
Posts: 2,945
Default Re: Got it wrong!!!

Hey BRS :)

What happens when you turn off your key and turn it back on again? Still nothing? Any moisture that got under the floor of your cart or near motor? Was this a gradual thing or did it happen all at once?
scubabud is offline   Reply With Quote
Unread 02-02-2014, 09:07 PM   #4
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: Got it wrong!!!

Can you hear the contactor click when you press the go pedal?
jjance is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
what did I do wrong??? Gas EZGO
Did I do wrong???? Electric EZGO
What have i done wrong here??? Electric Club Car
what's wrong with this kit ? Gas Club Car
What Did I Do Wrong ? Electric EZGO


All times are GMT -5. The time now is 06:29 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.