lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-06-2014, 08:52 AM   #1
Not Yet Wild
 
Join Date: Feb 2013
Posts: 64
Default stall/quit??

On 2 separate occasions in the last couple of weeks, my 2010 Precedent has "cut off" for a second while driving. In both instances, letting off the pedal and and stepping down again has "cleared" the issue. This last time I was running pretty good and the passenger was thrown forward for a second..

Any ideas what may be causing this?

It appears we also have an issue with the "in laws" cart. (a 96 Cub Car) The wife says it does't want to go unless you smash down on the pedal.

Any idea what can be causing this issue?

Thanks..
fastbasser is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-06-2014, 09:30 AM   #2
Gone Wild
 
PAPABEAR1's Avatar
Mixed Breed
 
Join Date: Nov 2013
Location: Aylett, Va. on the Mattaponi.
Posts: 1,530
Default Re: stall/quit??

More info may help .....
PAPABEAR1 is offline   Reply With Quote
Unread 03-06-2014, 09:39 AM   #3
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 4,583
Default Re: stall/quit??

My 2010 precedent did that last year, my problem was a bad cell in a battery. The problem was triggered by placing a large load on the system, like accelerating from 0 to full speed going up a hill. I replaced the entire pack and it has been running great since then.
There are other things that can cause a similar symptom, like a bad MCOR, but that would happen at the same throttle position and not be related to the load applied to the batteries.
Sergio is offline   Reply With Quote
Unread 03-06-2014, 09:56 AM   #4
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: stall/quit??

. . . the "infamous" solenoid drop-out?
Stevegrmich is offline   Reply With Quote
Unread 03-06-2014, 02:58 PM   #5
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,895
Default Re: stall/quit??

I think the solenoid dropout was mainly with first year (2002) IQ vehicles.
I would load test each battery while going up a hill and see if any of them drop considerably in voltage...
jakesnake27 is online now   Reply With Quote
Unread 03-06-2014, 04:17 PM   #6
Gone Wild
 
mymonstertruck's Avatar
Club Car
 
Join Date: Aug 2013
Location: Michigan
Posts: 508
Default Re: stall/quit??

My cart did that yesterday twice, I thought maybe it's the cold weather. And it cut out on a flat road no hills involved. I just let off the gas and pressed it back down and it was fine. I'll have to load test my batteries if it continues to do it. And my voltage read 42.5 volt when the accelerator was under load is that about right ?
mymonstertruck is offline   Reply With Quote
Unread 03-06-2014, 04:19 PM   #7
Gone Wild
 
mymonstertruck's Avatar
Club Car
 
Join Date: Aug 2013
Location: Michigan
Posts: 508
Default Re: stall/quit??

And both times I was driving on ice as well.
mymonstertruck is offline   Reply With Quote
Unread 03-06-2014, 04:22 PM   #8
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 4,583
Default Re: stall/quit??

Going up a hill WOT mine drops to about 46v. It is pretty hard to get a low reading on the battery as the controller shuts down very quickly when a battery drops, so you really need a meter with a hi/low function.
Sergio is offline   Reply With Quote
Unread 03-06-2014, 04:26 PM   #9
Gone Wild
 
mymonstertruck's Avatar
Club Car
 
Join Date: Aug 2013
Location: Michigan
Posts: 508
Default Re: stall/quit??

I was just going off my digital volt meter
mymonstertruck is offline   Reply With Quote
Unread 03-06-2014, 04:27 PM   #10
Gone Wild
 
mymonstertruck's Avatar
Club Car
 
Join Date: Aug 2013
Location: Michigan
Posts: 508
Default Re: stall/quit??

It might have been 46.5 but I think it was 42.5 I just put that gauge on the cart this winter so I haven't really had time to drive with it.
mymonstertruck is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Precedent Motor Stall Electric Club Car
G16a Hard Start and Stall Gas Yamaha
1986 club car stall Gas Club Car
G16 Surge-Stall-Surge-Stall... FIXED Gas Yamaha
complete stall going up hill Electric EZGO


All times are GMT -5. The time now is 09:27 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.