lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-06-2014, 10:53 AM   #1
Not Yet Wild
 
CabinetGuy's Avatar
Club Car
 
Join Date: Oct 2013
Location: Oldsmar, FL
Posts: 21
Default Turn signal kit not flashing

I just installed the turn signal and brake light kits from Nivel after installing the headlight/taillight kit about 6 months ago.

Everything lights up as intended with exception to the turn signals. They do not flash. I thought the flasher may be bad so I bought a new one from the local auto parts store but it does the same thing.

I'm wondering if the LED's are the cause, as the taillights have LED's and I changed the headlight halogens to LED's. I am running off of a single 12V deep cycle battery.

Any suggestions? I have verified all wiring. The only thing I'm sketchy on is that the original light kit came with 3 wires; red, white and black. I found that the white wire went to the marker lights on the front and was tied in with the red light, so I split it off and ran it to the turn signal indicator used for each turn signal. They light up when I put the turn signal in their direction but do not flash.
CabinetGuy is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-06-2014, 11:13 AM   #2
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: Turn signal kit not flashing

. . . you may need to change the flasher to one for LED's . . . like this one . . .

LED Flasher
Stevegrmich is offline   Reply With Quote
Unread 03-06-2014, 02:56 PM   #3
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,881
Default Re: Turn signal kit not flashing

I agree with Steve, I bet that's your problem...
jakesnake27 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
turn signal kit Electric Club Car
Turn Signal Help Electric EZGO
85 Club Car turn indicators not flashing Gas Club Car
Turn signal help Lifted Golf Carts
turn signal Test Post


All times are GMT -5. The time now is 02:29 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.