lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-11-2014, 06:33 AM   #1
Not Yet Wild
 
Join Date: Mar 2014
Posts: 8
Default clicking sound

i have a 89 club cart that will go really slow in rev. but want go in foward. i have checked all the wires i had a couple wires backwards fixed that. the batteries are not even a year old. when i tried yesterday for it to go in fowards it was making a clicking sound. It sounded like it was coming out of the motor. i am getting the 36 volts in forward but only 16 in rev. i have no clue what it is. can someone please help thanks
jraney is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-11-2014, 06:55 AM   #2
Not here yet
 
branson's Avatar
E-Z-GO
 
Join Date: Sep 2013
Location: jupiter florida
Posts: 495
Default Re: clicking sound

I think we're going to need a little bit more information than that. year make model. the exact voltage readings on the battery. if there is clicking probably this solenoid which is good
branson is offline   Reply With Quote
Unread 03-11-2014, 01:07 PM   #3
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,910
Default Re: clicking sound

Welcome to BGW jraney...

The cart is wired stock to have half voltage reverse. I would load test each battery individually.
jakesnake27 is offline   Reply With Quote
Unread 03-11-2014, 02:54 PM   #4
Not Yet Wild
 
Join Date: Mar 2014
Posts: 8
Default Re: clicking sound

it is 1989 club car it is a 36 volt. i have check each battery they are reading normal, chrager is reading normal. the votage reading is 6. im getting 16 volts in reverse and 36 in forward. i charged it the other night over night and thats what it does will go in reverse slowly but will not go in foward
jraney is offline   Reply With Quote
Unread 03-11-2014, 03:01 PM   #5
Not here yet
 
branson's Avatar
E-Z-GO
 
Join Date: Sep 2013
Location: jupiter florida
Posts: 495
Default Re: clicking sound

looking back at your first post. you say you checked the wires and that some of them were backwards. how did they get back words was the cart not working when you got it. do they have anything to do with the forward reverse switch
branson is offline   Reply With Quote
Unread 03-11-2014, 07:05 PM   #6
Not Yet Wild
 
Join Date: Mar 2014
Posts: 8
Default Re: clicking sound

The wires were put on wrong when I put the batteries in. They didn't have anything to do with the forward and reverse.
jraney is offline   Reply With Quote
Unread 03-11-2014, 09:52 PM   #7
Gone Wild
 
Join Date: Jul 2012
Posts: 912
Default Re: clicking sound

New bats? if so still charge them before use. Hooking up cables wrong could be your problem, either fried something or still not hooked right. More info would be good, did you see sparks?
Speedchaser is offline   Reply With Quote
Unread 03-12-2014, 08:28 AM   #8
Not Yet Wild
 
Join Date: Mar 2014
Posts: 8
Default Re: clicking sound

I got a wire diagram and went through all the wires for the batteries and the white that goes from the battery to the switch was in the wrong place but fixed that and it's still not wanting to go
jraney is offline   Reply With Quote
Unread 03-12-2014, 08:43 AM   #9
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,093
Default Re: clicking sound

36v forward and 18v reverse is standard operation for this cart. Clicking sound is usually coming from the solenoid. The sound is the solenoid engaging/disengaging rapidly. This is caused by low voltage (this is bad for the solenoid). Check your pack voltage under load.
scottyb is offline   Reply With Quote
Unread 03-12-2014, 09:28 AM   #10
Not Yet Wild
 
Join Date: Mar 2014
Posts: 8
Default Re: clicking sound

Would that make the cart not want to go in foward
jraney is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
clicking sound Electric EZGO
2009 rxv clicking sound Gas EZGO
Clicking sound and wont run Gas EZGO
Clicking sound in rear Electric EZGO
That clicking sound Electric EZGO


All times are GMT -5. The time now is 05:47 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.