lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-25-2014, 03:20 PM   #1
Not Yet Wild
 
Join Date: Jun 2011
Posts: 22
Default speed problem

I have a 2008 club car precedent IQ. When I step on the throttle it starts to go fast but then it just goes along very slowly. I've replaced the speed sensor magnet in the motor and the controller but nothing helps. Any suggestions as to what I can do
Bernie
bernieseibert is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-25-2014, 03:23 PM   #2
Not Yet Wild
 
goheelzfan's Avatar
Club Car
 
Join Date: Mar 2014
Location: North Carolina
Posts: 61
Default Re: speed problem

Did you replace the speed sensor?
goheelzfan is offline   Reply With Quote
Unread 03-25-2014, 03:26 PM   #3
Not Yet Wild
 
Join Date: Jun 2011
Posts: 22
Default Re: speed problem

If you mean the magnet in the back of the motor , tes
bernieseibert is offline   Reply With Quote
Unread 03-25-2014, 03:27 PM   #4
Not Yet Wild
 
Join Date: Jun 2011
Posts: 22
Default Re: speed problem

that should have said yes
bernieseibert is offline   Reply With Quote
Unread 03-25-2014, 03:32 PM   #5
Not Yet Wild
 
goheelzfan's Avatar
Club Car
 
Join Date: Mar 2014
Location: North Carolina
Posts: 61
Default Re: speed problem

I had the same problem and I replaced the magnet and the speed sensor. (speed sensor is the wire and black cap over the magnet)
goheelzfan is offline   Reply With Quote
Unread 03-25-2014, 03:36 PM   #6
Not Yet Wild
 
Join Date: Jun 2011
Posts: 22
Default Re: speed problem

Yeah maybe that's the problem thanks I'll try that
bernieseibert is offline   Reply With Quote
Unread 03-25-2014, 03:38 PM   #7
Not Yet Wild
 
Join Date: Jun 2011
Posts: 22
Default Re: speed problem

Who sells the speed sensor
bernieseibert is offline   Reply With Quote
Unread 03-25-2014, 03:56 PM   #8
Not Yet Wild
 
goheelzfan's Avatar
Club Car
 
Join Date: Mar 2014
Location: North Carolina
Posts: 61
Default Re: speed problem

ebay or amazon, also find out if it has 2 screws holding it in.
goheelzfan is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
08 precedent electric speed sensor problem. Cart starts at proper speed then slows . Electric Club Car
Half speed, speed sensor problem?. Electric Club Car
Speed Problem Electric Club Car
Speed Problem Electric Yamaha
speed problem xt 500 Electric EZGO


All times are GMT -5. The time now is 11:48 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.