Buggies Gone Wild Golf Cart Forum

Buggies Gone Wild Golf Cart Forum (http://www.buggiesgonewild.com/)
-   Electric Club Car (http://www.buggiesgonewild.com/electric-club-car/)
-   -   Another charger issue Powerdrive 2 (http://www.buggiesgonewild.com/electric-club-car/91857-another-charger-issue-powerdrive-2-a.html)

1970buick 03-26-2014 06:54 PM

Another charger issue Powerdrive 2
 
So I plug the charger into the cart tonight and nothing. Cables are all good. Batteries are showing 49.2 volts but they haven't been charged in a couple weeks. Not been driven either. No "click" when I plug the charger in. I am guessing the relay but cant figure out how it would go bad in between charges. 2008.5 precedent 48v Powerdrive 2 charger, second charger in 18months. The original powerdrive 3 just stopped working one day also. Also it feels like there is no resistance in the reset button. It just feels loose and has always been like that

Stevegrmich 03-27-2014 05:33 AM

Re: Another charger issue Powerdrive 2
 
1. Try spraying some WD40 into cart's receptacle.
2. Poor connection at 10-gauge black wire or 18-gauge gray wire at the OBC.
3. Try driving cart a few feet, then plug in charger.
4. Try the OBC bypass procedure in the charger to rule out OBC failure.
5. Verify power at house outlet.

1970buick 03-27-2014 06:26 AM

Re: Another charger issue Powerdrive 2
 
Thanks. I will try those steps and report results.

1970buick 03-29-2014 06:33 PM

Re: Another charger issue Powerdrive 2
 
Quote:

Originally Posted by Stevegrmich (Post 1005144)
1. Try spraying some WD40 into cart's receptacle.
2. Poor connection at 10-gauge black wire or 18-gauge gray wire at the OBC.
3. Try driving cart a few feet, then plug in charger.
4. Try the OBC bypass procedure in the charger to rule out OBC failure.
5. Verify power at house outlet.

I took the charger to a local shop and hooked it up to one of their DS carts and it turned on in about 5 seconds. So the charger is good.
1. WD-40 did not work
2. Double checked power from garage outlet, good
3.Checked connections on back of OBC, good
4.Went forward and back a few feet, still nothing.
5. Did OBC bypass, but did I do it correctly?
I ran the black wire from the charging part to the negative terminal of the battery that has the wire that runs through the OBC. I took that wire off and replaced it with the wire from directly behind the receptacle.

TahoeDawgZ71 03-29-2014 10:12 PM

Re: Another charger issue Powerdrive 2
 
You didn't trigger the relay by tapping ground to the tip of the control lead fuse


All times are GMT -5. The time now is 04:08 PM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.