lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-18-2014, 08:52 AM   #11
Not Yet Wild
 
Join Date: Sep 2013
Posts: 7
Default Re: Cart running very slow

I have contacted the seller but no reply as of yet. I have used micrometer on all parts and the only thing I see in question is the mounting holes are elongated which would allow you to mount the sensor alittle off center.
My question is the quality of the part.
Is a $200 sensor that much better quality than a $60 sensor. What is your experience. I dont mind spending more money if I know the part is of that much better quailty.
neilgw is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-18-2014, 09:52 AM   #12
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,978
Default Re: Cart running very slow

I'm sure a factory sensor would be better. The holes shouldn't be elongated.
TahoeDawgZ71 is offline   Reply With Quote
Unread 04-21-2014, 06:30 PM   #13
Gone Wild
 
Join Date: Aug 2011
Posts: 384
Default Re: Cart running very slow

I was looking at your pictures and noticed that the color of your speed sensor wires were red, black and blue I think these sensors are made in china and match the ones i have seen on Alibaba for under $20.00. The home grown sensors use a green wire instead of blue.
greg-g is offline   Reply With Quote
Unread 04-30-2014, 08:28 PM   #14
Not Yet Wild
 
Join Date: Sep 2013
Posts: 7
Default Re: Cart running very slow

I went to the club car dealership and bought a a OEM sensor and magnet. Installed it in the cart. The cart is still running slow. the motor break is functioning in rollaway conditions so i know the speed sensor is working. The cart does not take off with good torque and then slow down, is just runs very slow and steady. The cheap sensor I bought controlled the motor break in runaway situations even with the broke wires in the sensor winding. still trying to resolve my problem.
neilgw is offline   Reply With Quote
Unread 04-30-2014, 11:36 PM   #15
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,978
Default Re: Cart running very slow

Quote:
Originally Posted by neilgw View Post
I went to the club car dealership and bought a a OEM sensor and magnet. Installed it in the cart. The cart is still running slow. the motor break is functioning in rollaway conditions so i know the speed sensor is working. The cart does not take off with good torque and then slow down, is just runs very slow and steady. The cheap sensor I bought controlled the motor break in runaway situations even with the broke wires in the sensor winding. still trying to resolve my problem.
Take it back to that dealership and have them scan your cart with an IQDM scan machine. It'll tell you exactly what's wrong with it.
TahoeDawgZ71 is offline   Reply With Quote
Unread 05-01-2014, 01:40 PM   #16
Not Yet Wild
 
Join Date: Sep 2013
Posts: 7
Default Re: Cart running very slow

Cart repaired!

Took pedals out this morning to test ohm reading on MCOR. Tested good. found a little corrosion on contacts. sprayed all contacts with contact cleaner. install all back in with di electric compound. Cart ran like a champ. a little corrosion on the contacts was what was causing my latest problem.

Thanks for everyones help.
neilgw is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Club Cart Running Slow Lifted Golf Carts
cart running slow Electric Club Car
77 3 wheeled golf cart running very slow Gas EZGO
Update on cart running slow not charging Electric EZGO
Cart alternates from running fast to slow. Gas Yamaha


All times are GMT -5. The time now is 05:41 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.