lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-19-2014, 02:40 PM   #1
Not Yet Wild
 
crum83bc's Avatar
E-Z-GO
 
Join Date: Apr 2014
Location: Grand Rapids, MI
Posts: 21
Default 2010 Precedent 48v burning smell

Started smelling a burning smell when going uphill. Replaced the batteries, lubed front and rear. No noticeably warm or damaged wires. Seems like it's coming from the front. Any suggestions?
crum83bc is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-19-2014, 02:48 PM   #2
Not Yet Wild
 
Join Date: Dec 2013
Posts: 50
Default Re: 2010 Precedent 48v burning smell

Are your baterry cables getting hot? It happened to mine and I had to install bigger cables.
jlensi is offline   Reply With Quote
Unread 04-19-2014, 03:06 PM   #3
Not Yet Wild
 
crum83bc's Avatar
E-Z-GO
 
Join Date: Apr 2014
Location: Grand Rapids, MI
Posts: 21
Default Re: 2010 Precedent 48v burning smell

The shortest wire between batteries gets warm, not hot. Crimps and the wire connections look good.
crum83bc is offline   Reply With Quote
Unread 04-19-2014, 07:58 PM   #4
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: 2010 Precedent 48v burning smell

Do your electrics (lights horn etc ) work OK. All that stuff is located up front. A lot of it dangles underneath by the headlight.
jjance is offline   Reply With Quote
Unread 04-20-2014, 11:40 AM   #5
Not Yet Wild
 
crum83bc's Avatar
E-Z-GO
 
Join Date: Apr 2014
Location: Grand Rapids, MI
Posts: 21
Default Re: 2010 Precedent 48v burning smell

Everything is working fine.
crum83bc is offline   Reply With Quote
Unread 04-20-2014, 12:31 PM   #6
Gone Wild
 
scooterman's Avatar
Club Car
 
Join Date: Jan 2014
Location: Lafayette, Louisiana
Posts: 1,641
Default Re: 2010 Precedent 48v burning smell

Remove that cable that was getting warm, look for discoloration.
scooterman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Burning Smell Electric EZGO
Electrical burning smell Electric Yamaha
Burning smell Electric EZGO
Still have burning smell Electric EZGO
Burning Smell And Hot Cables Electric EZGO


All times are GMT -5. The time now is 12:10 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.