lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-22-2014, 08:40 PM   #1
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,982
Default New to me cart

Well I know I've gone wild now. For no good reason I just bought a 1999 club car DS ser# a9937 xxxxxx. It has a tow run switch, 48 volt t875 batteries date e7. Never took a good look but there is something between the center batteries and the left ones. Could this be a v glide. It has a single coil in the rear on the left side. It has a controller. What have I got myself into. Btw it does run I have it on charge now. I will check the batteries tomorrow. The guy I got it from said the cart has set for about 6 months and the batteries only have about 10 to 20 rounds of golf. He moved away from town and rarely plays golf anymore.
mrgolf is online now   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-22-2014, 08:50 PM   #2
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,982
Default Re: New to me cart

image.jpg
mrgolf is online now   Reply With Quote
Unread 04-22-2014, 08:53 PM   #3
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,982
Default Re: New to me cart

image.jpg[attach]
mrgolf is online now   Reply With Quote
Unread 04-22-2014, 08:56 PM   #4
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,982
Default Re: New to me cart

image.jpg
mrgolf is online now   Reply With Quote
Unread 04-22-2014, 09:36 PM   #5
ΜΟΛΩΝ ΛΑΒΕ
 
93yellowclubcar's Avatar
Club Car
 
Join Date: Nov 2012
Location: West Virginia
Posts: 4,094
Default Re: New to me cart

Something between the batteries on the left frame rail sounds like a vglide. Got a pic?
93yellowclubcar is offline   Reply With Quote
Unread 04-22-2014, 09:47 PM   #6
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,982
Default Re: New to me cart

image.jpg

Here it is.
mrgolf is online now   Reply With Quote
Unread 04-22-2014, 09:59 PM   #7
Gone Wild
 
CartTrader's Avatar
Club Car
 
Join Date: Aug 2008
Location: Ohio-In Summer, Central Florida-In winter
Posts: 887
Default Re: New to me cart

Yup Vglide!!

CartTrader
CartTrader is online now   Reply With Quote
Unread 04-22-2014, 10:01 PM   #8
ΜΟΛΩΝ ΛΑΒΕ
 
93yellowclubcar's Avatar
Club Car
 
Join Date: Nov 2012
Location: West Virginia
Posts: 4,094
Default Re: New to me cart

Yup, that there be a V-Glide!

Club Car did some funky stuff in those years concerning throttle devices, some carts had pot boxes under the floor, the MCOR came out somewhere in there, and they still continued to use the V-Glide as well. Personally, I like the V-Glide setup and I've never had it let me down.

One thing you might do sometime is pop off the cover and make sure the wiper arm contact rides evenly on the other contacts, and clean them up with a piece of emery cloth.

EDIT: CT beat me to it cause I got longwinded again...
93yellowclubcar is offline   Reply With Quote
Unread 04-22-2014, 10:11 PM   #9
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,908
Default Re: New to me cart

You've got a Regen 2! The MCOR began in 2001, the pot boxes were 95-96 and they were so bad that CC went back to the v-glide...
jakesnake27 is online now   Reply With Quote
Unread 04-22-2014, 10:13 PM   #10
ΜΟΛΩΝ ΛΑΒΕ
 
93yellowclubcar's Avatar
Club Car
 
Join Date: Nov 2012
Location: West Virginia
Posts: 4,094
Default Re: New to me cart

Quote:
Originally Posted by jakesnake27 View Post
You've got a Regen 2! The MCOR began in 2001, the pot boxes were 95-96 and they were so bad that CC went back to the v-glide...
I thought it might have been a regen cart cause he mentioned a coil back there. And that was a good post, I learned something!
93yellowclubcar is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes



All times are GMT -5. The time now is 08:29 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.