lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-07-2014, 10:26 PM   #21
Gone Wild
 
Budule's Avatar
Club Car
 
Join Date: Sep 2010
Posts: 488
Default Re: Something is slipping

Quote:
Originally Posted by ROOKEE View Post
Quote:
Originally Posted by Budule
that's a little less than 70% so they need charged......what does the voltage drop to under load ? Try leaving volt meter hooked up so you can see it while driving , then try the slow take off and then the fast one to see if its dropping out on you......also may want to test batteries individually to see if all are low or maybe just one is the culprit.....


I left the volt meter hooked up and drove it.
That where I got the load test from.
and the voltage stayed at 48 even while it was "slipping" ?
Budule is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-08-2014, 06:10 PM   #22
Not Yet Wild
 
ROOKEE's Avatar
Club Car
 
Join Date: Mar 2014
Location: valleygrande alabama
Posts: 15
Default Re: Something is slipping

Quote:
Originally Posted by Budule View Post
and the voltage stayed at 48 even while it was "slipping" ?
That's just it, I had the cart jacked up when I
Load tested it and it didn't slip while jacked up .
Just when it's on the ground.
I'm sorry guys, I know this is aggravating. It is
To me as well. My kids ask me everyday,"hey daddy
Is the cart ready yet " and I keep letting them down.
Guess I will have to find a shop to take it to.
There isn't anyone in Selma AL. That works on them.
ROOKEE is offline   Reply With Quote
Unread 05-08-2014, 06:24 PM   #23
Gone Wild
 
DJBlade's Avatar
Club Car
 
Join Date: Dec 2011
Location: Columbia, South Carolina
Posts: 258
Default Re: Something is slipping

You have a bad battery or multiple bad batteries under load. Take it to your local dealership and have the batteries tested and replaced. Any shortcuts on batteries will ensure your problem will arise again and again.
DJBlade is offline   Reply With Quote
Unread 05-08-2014, 06:46 PM   #24
Gone Wild
 
Budule's Avatar
Club Car
 
Join Date: Sep 2010
Posts: 488
Default Re: Something is slipping

Quote:
Originally Posted by ROOKEE View Post
That's just it, I had the cart jacked up when I
Load tested it and it didn't slip while jacked up .
Just when it's on the ground.
I'm sorry guys, I know this is aggravating. It is
To me as well. My kids ask me everyday,"hey daddy
Is the cart ready yet " and I keep letting them down.
Guess I will have to find a shop to take it to.
There isn't anyone in Selma AL. That works on them.
You cant really load test it jacked up as there isn't really a load on it at that point.....leave meter hooked up and actually drive it around , up hill , with a passenger if possible and watch voltage then.....
Budule is offline   Reply With Quote
Unread 05-09-2014, 07:22 PM   #25
Not Yet Wild
 
ROOKEE's Avatar
Club Car
 
Join Date: Mar 2014
Location: valleygrande alabama
Posts: 15
Default Re: Something is slipping

Quote:
Originally Posted by Budule View Post
You cant really load test it jacked up as there isn't really a load on it at that point.....leave meter hooked up and actually drive it around , up hill , with a passenger if possible and watch voltage then.....
Ok, drove cart with volt meter hooked up.
The lead battery drops to negative reading. The only positive
Reading I could see on the lead battery was 3volts under a load.
All other batteries stayed the same under load.
I hope this is narrowing down my problem.
What does all this tell me???
ROOKEE is offline   Reply With Quote
Unread 05-09-2014, 07:38 PM   #26
Gone Wild
 
Budule's Avatar
Club Car
 
Join Date: Sep 2010
Posts: 488
Default Re: Something is slipping

Quote:
Originally Posted by ROOKEE View Post
Ok, drove cart with volt meter hooked up.
The lead battery drops to negative reading. The only positive
Reading I could see on the lead battery was 3volts under a load.
All other batteries stayed the same under load.
I hope this is narrowing down my problem.
What does all this tell me???
That you need at least 1 battery to correct the "slipping"........but since none of them are really charging all the way up , a full set is in your future $$$$$
Budule is offline   Reply With Quote
Unread 05-09-2014, 07:50 PM   #27
Gone Wild
 
Budule's Avatar
Club Car
 
Join Date: Sep 2010
Posts: 488
Default Re: Something is slipping

All this is assuming you have checked the cables for a bad connection , .......now you CAN go to a auto zone or advance auto if they sell golf cart batteries and see if they have an "new , old one " ( mine did , they had 2 or 3 he had had for over a year that he couldn't sell as new , so he made me a deal ) and I have done this and "limped " my cart around like this for quite some time , but mine was just a "yard cart" and never far from home.....if your cart is the one in your avatar , I wouldn't hesitate to put a new full set in there cause that's a nice looking cart......
Budule is offline   Reply With Quote
Unread 05-09-2014, 09:47 PM   #28
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,981
Default Re: Something is slipping

A week and a half later we have an answer.............. low voltage. Hate say I told ya so but.............. I see it almost every day of my life.
TahoeDawgZ71 is offline   Reply With Quote
Unread 05-09-2014, 10:01 PM   #29
Gone Wild
 
Budule's Avatar
Club Car
 
Join Date: Sep 2010
Posts: 488
Default Re: Something is slipping

Quote:
Originally Posted by TahoeDawgZ71 View Post
A week and a half later we have an answer.............. low voltage. Hate say I told ya so but.............. I see it almost every day of my life.


Budule is offline   Reply With Quote
Unread 05-09-2014, 10:08 PM   #30
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,981
Default Re: Something is slipping

Budule.... I reckon you nailed it... mmmhmmm
TahoeDawgZ71 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Belt slipping Gas EZGO
Belt slipping Gas EZGO
G22 Belt slipping Gas Yamaha
belt slipping Gas Yamaha
belt slipping when wet. Gas Yamaha


All times are GMT -5. The time now is 08:18 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.