lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-30-2014, 02:12 PM   #1
Not Yet Wild
 
Join Date: Apr 2014
Posts: 9
Default 1981 36V Club Car, New Batteries installed but won't charge

I recently purchased a 1981 36V Electric Club Car (my first cart) and replaced the batteries with new 6 new batteries. I would connect the charger after each use. I noticed the amps on the charger would not go up when attached but assumed that new batteries didn't need much charging. But now my battery meter on the cart is just above 60%. It is not charging. I reset the OBC a few times but that did not help. (still not sure if the cart has one as I cant visually find it, diagrams I found do not point to one and searching with the question brings nothing up). When I do the OBC reset, I hear a click and the battery meter goes to 100% for a while but goes right back down to 60% after a short ride. I tested the charger and its working fine. What am I missing?? Please help.

Thanks,
Albehym
Albehym is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-30-2014, 02:19 PM   #2
Getting Wild
Club Car
 
Join Date: May 2010
Location: Pennsylvania
Posts: 97
Default Re: 1981 36V Club Car, New Batteries installed but won't charge

You sure it's a 1981? And what type of charger?
physcoflip is offline   Reply With Quote
Unread 04-30-2014, 02:55 PM   #3
Not Yet Wild
 
Join Date: Apr 2014
Posts: 9
Default Re: 1981 36V Club Car, New Batteries installed but won't charge

Club Car Number A8103-17936. Charger: Lester matic. Model# 8714. Type 36LC25T12. 115V.

(Thanks for your reply)
Albehym is offline   Reply With Quote
Unread 04-30-2014, 04:21 PM   #4
STEALTH 4X4
 
sunoco's Avatar
Club Car
 
Join Date: Sep 2011
Location: GA
Posts: 2,017
Default Re: 1981 36V Club Car, New Batteries installed but won't charge

You don't have an OBC. Make sure the charger receptacle and batteries are wired correctly

What kind of batteries did you put in it?
sunoco is offline   Reply With Quote
Unread 04-30-2014, 04:43 PM   #5
Not Yet Wild
 
Join Date: Apr 2014
Posts: 9
Default Re: 1981 36V Club Car, New Batteries installed but won't charge

Thanks for your feedback. I will check the wiring. Just to get my mind right, a cart can run even if you wire it incorrectly?

Autocraft Golf Cart 6-Volt Deep-Cycle Service Battery. 6 of them.
Albehym is offline   Reply With Quote
Unread 04-30-2014, 04:54 PM   #6
Gone Wild
 
Budule's Avatar
Club Car
 
Join Date: Sep 2010
Posts: 488
Default Re: 1981 36V Club Car, New Batteries installed but won't charge

Make sure the wire from the charge port (#7) that goes to the negative post on the battery didn't drop down and hide from you when you changed batteries....
Budule is offline   Reply With Quote
Unread 04-30-2014, 10:08 PM   #7
Not Yet Wild
 
Join Date: Apr 2014
Posts: 9
Default Re: 1981 36V Club Car, New Batteries installed but won't charge

Triple checked wiring. I'm good. And still lost...
Albehym is offline   Reply With Quote
Unread 04-30-2014, 10:27 PM   #8
Gone Wild
 
Budule's Avatar
Club Car
 
Join Date: Sep 2010
Posts: 488
Default Re: 1981 36V Club Car, New Batteries installed but won't charge

So if you put a voltmeter across the pack WITHOUT the charger plugged in you should get 37 something volts and your saying that the volts don't go up WHEN you plug in the charger?
Budule is offline   Reply With Quote
Unread 04-30-2014, 10:57 PM   #9
Gone Wild
 
Scott H.'s Avatar
Club Car
 
Join Date: May 2011
Location: Charleston, South Carolina
Posts: 672
Default Re: 1981 36V Club Car, New Batteries installed but won't charge

Check for corrosion on the terminals and for bad connections. I've had wires look good, but didn't pass a continuity check with a meter due to corrosion.

-Scott H.
Scott H. is offline   Reply With Quote
Unread 04-30-2014, 11:10 PM   #10
Not Yet Wild
 
Join Date: Apr 2014
Posts: 9
Default Re: 1981 36V Club Car, New Batteries installed but won't charge

Budule- without charger I get 36.5v. With charger on, 36.6v. Five batteries read 6.1, one battery reads 5.7 (number 4 battery).

Scott- I start cleaning tomorrow.
Albehym is offline   Reply With Quote
Reply

Tags
1981, new batteries installed, reset obc, won't charge
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
07 Club Car Precedent---Lights stopped working after new batteries installed Electric Club Car
club cart batteries won't charge better than 6.5 out of 15 Electric Club Car
98 Club Car DS 48V, batteries won't charge Electric Club Car
97 Club Car 48V DS Charger's Stopped Coming On shortly after New Batteries Installed Electric Club Car
Club Car battery charger won't charge new batteries Electric golf carts


All times are GMT -5. The time now is 03:59 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.