lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-03-2014, 09:25 AM   #1
Not Yet Wild
 
Join Date: May 2014
Location: Gibbons Alberta
Posts: 5
Default 2002 clubcar ds was running fine put lift kit in now clicks and does not move

after stripping down my 2002 club car ds we added a lift kit ..tires and a new paint job the cart wont move push pedal and it clicks that's all. Is it possible that if F/R switch is wired wrong could cause it? or is there steps to trouble shoot to see if more serious problem...places to measure voltage? making sure I have full power to motor? I know I have 48v to controller. any suggestions would be helpful. Thanks
gordborg is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-03-2014, 09:56 AM   #2
Gone Wild
 
Jd62's Avatar
E-Z-GO
 
Join Date: Dec 2013
Location: Montreal Qc
Posts: 662
Default Re: 2002 clubcar ds was running fine put lift kit in now clicks and does not move

Hi, welcome to bgw,, did you touch any wire when you've done this job.... If not you should check your batterie voltage one by one....
Jd62 is offline   Reply With Quote
Unread 05-03-2014, 09:01 PM   #3
Not Yet Wild
 
Join Date: May 2014
Location: Gibbons Alberta
Posts: 5
Default Re: 2002 clubcar ds was running fine put lift kit in now clicks and does not move

well its my first golf cart ..checked all batteries are go tested solenoid's all good..check low voltage test on motor in ran..found a controller from my friends car tried it and it worked tried my controller in his didn't work. has a good awful smell to it..so now I need a new one any suggestions...oh and it a 2000 not 2002..found serial #
gordborg is offline   Reply With Quote
Unread 05-04-2014, 01:25 PM   #4
Not Yet Wild
 
Join Date: May 2014
Posts: 1
Default Re: 2002 clubcar ds was running fine put lift kit in now clicks and does not move

Pull the cover off of your controller and see if you didn't pull a wire loose from its connection when you were moving your rear end on the leaf springs. Been there done that.
1henry is offline   Reply With Quote
Unread 05-04-2014, 01:38 PM   #5
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,029
Default Re: 2002 clubcar ds was running fine put lift kit in now clicks and does not move

try scotyB >>> http://www.cartsunlimited.net/Custom_Options.html
crash test dummy is offline   Reply With Quote
Unread 05-05-2014, 03:18 PM   #6
Not Yet Wild
 
Join Date: May 2014
Location: Gibbons Alberta
Posts: 5
Default Re: 2002 clubcar ds was running fine put lift kit in now clicks and does not move

thanks!
gordborg is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
gas clubcar runs fine then dies Gas Club Car
clubcar clicks but doesnt move Electric Club Car
bad boy want go, worked fine parkes for a while now want move Electric EZGO
Thanks to everyone here, cc 2002 ds runs fine now Electric Club Car
2002 Club Car DS 48v. Runs fine then shuts down. Electric Club Car


All times are GMT -5. The time now is 12:30 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.