lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-08-2014, 09:56 AM   #31
Getting Wild
Club Car
 
Join Date: Sep 2013
Location: Western Pa
Posts: 107
Default Re: click but no go !!!! help

Yes it did at one time. Second one was for regen breaking it all has been removed.
jeremie1976 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-08-2014, 10:09 AM   #32
Gone Wild
 
scooterman's Avatar
Club Car
 
Join Date: Jan 2014
Location: Lafayette, Louisiana
Posts: 1,643
Default Re: click but no go !!!! help

re-cap
Cart was working fine with original motor correct? So you wanted to upgrade so you had the motor rebuilt by PQ. Installed the rebuilt motor and dead. When this was done, was there anything else you touched? When you connected power after replacing the motor, did you spark anything? I'm taking it the new motor has never run, when you ordered it did you give them the exact information on your cart, what was changed or altered from factory?
You swapped controller but is there a way to test either one on a different cart to make sure they both aren't burnt up? It seems the solenoid is switching but not getting control power at the right times.
scooterman is offline   Reply With Quote
Unread 05-08-2014, 10:15 AM   #33
Getting Wild
Club Car
 
Join Date: Sep 2013
Location: Western Pa
Posts: 107
Default Re: click but no go !!!! help

Cart was working fine with alltrax controller an stock motor. Then it just stopped. Thinking it was the motor so had it redone now still same problem with aftermarket motor an both stock an alltrax controllers. I'm thinking something else went before I had the motor done. Cart trys to move but then it loses voltage from the solenoid to the controller.
jeremie1976 is offline   Reply With Quote
Unread 05-08-2014, 10:31 AM   #34
Gone Wild
 
scooterman's Avatar
Club Car
 
Join Date: Jan 2014
Location: Lafayette, Louisiana
Posts: 1,643
Default Re: click but no go !!!! help

Inside An MCOR 01-04 DS

Ok Assuming without further testing you are correct, then lets look at the MCOR.

This link is helpful, go through the pages and get a good understanding of how it works, this was an 04 but I'm guessing you have something similar, the Multi Step potentiometer is what the go pedal actuates.
scooterman is offline   Reply With Quote
Unread 05-08-2014, 10:33 AM   #35
Getting Wild
Club Car
 
Join Date: Sep 2013
Location: Western Pa
Posts: 107
Default Re: click but no go !!!! help

Sorry mine don't have that one. Its the vglide or pie shape under the driver side with brass scales.
jeremie1976 is offline   Reply With Quote
Unread 05-08-2014, 10:39 AM   #36
Gone Wild
 
scooterman's Avatar
Club Car
 
Join Date: Jan 2014
Location: Lafayette, Louisiana
Posts: 1,643
Default Re: click but no go !!!! help

Quote:
Originally Posted by jeremie1976 View Post
Sorry mine don't have that one. Its the vglide or pie shape under the driver side with brass scales.
Well can you test it, it is a variable POT, which is basically a bunch of resistors, (one for each circuit or step) disconnect power from it and test to see if each one has a steady decrease or increase in resistance if you can or is it sealed up? You want to test each step separately if possible.
scooterman is offline   Reply With Quote
Unread 05-08-2014, 10:59 AM   #37
Getting Wild
Club Car
 
Join Date: Sep 2013
Location: Western Pa
Posts: 107
Default Re: click but no go !!!! help

Ok no I have had it apart before to clean the brass contacts. It also has a micro switch in it but it tested OK
jeremie1976 is offline   Reply With Quote
Unread 05-08-2014, 11:07 AM   #38
Gone Wild
 
scooterman's Avatar
Club Car
 
Join Date: Jan 2014
Location: Lafayette, Louisiana
Posts: 1,643
Default Re: click but no go !!!! help

that is no you can't test it?
scooterman is offline   Reply With Quote
Unread 05-08-2014, 11:11 AM   #39
Gone Wild
 
scooterman's Avatar
Club Car
 
Join Date: Jan 2014
Location: Lafayette, Louisiana
Posts: 1,643
Default Re: click but no go !!!! help

I see the OBC has a red/white wire to that solenoid, is that all still wired up
scooterman is offline   Reply With Quote
Unread 05-08-2014, 11:13 AM   #40
Getting Wild
Club Car
 
Join Date: Sep 2013
Location: Western Pa
Posts: 107
Default Re: click but no go !!!! help

Sorry I can test it. It is still wired up it is under the battery side of the solenoid. It looks like it ties into the tow/run switch
jeremie1976 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
RXV 2009 click click but won't move Electric EZGO
G9 all we get is a Click Electric Yamaha
No click, click, when I hook up my charger? Electric Club Car
Click Click - will not move ! Electric EZGO
no click Electric Club Car


All times are GMT -5. The time now is 05:33 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.