lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-08-2014, 11:10 AM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Nov 2013
Location: Phoenix AZ
Posts: 8
Default jerryk

I just got this cart and need to ask a question on throttle issue. The cart runs great but when i let up on petal it slows down real fast,like the brake is down. Is this normal.? I checked the threads and did not find any with this issue. Thanks in advance for any reply.
jk1022 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-08-2014, 12:11 PM   #2
Gone Wild
 
55BigBlock's Avatar
Club Car
 
Join Date: Feb 2013
Location: NC/SC
Posts: 737
Default Re: jerryk

You need to post the year and model but it is probably regen braking which is normal.
55BigBlock is offline   Reply With Quote
Unread 05-08-2014, 12:33 PM   #3
Not Yet Wild
E-Z-GO
 
Join Date: Nov 2013
Location: Phoenix AZ
Posts: 8
Default Re: jerryk

It is a 2010 .I had a 87 EZGO and never experinced this before. I just want to make sure that this is normal, or if it is a problem.
jk1022 is offline   Reply With Quote
Unread 05-08-2014, 04:05 PM   #4
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,862
Default Re: jerryk

It's probably the regen braking. Does it do it just while going down hill or every time?
jakesnake27 is offline   Reply With Quote
Unread 05-08-2014, 07:29 PM   #5
Not Yet Wild
E-Z-GO
 
Join Date: Nov 2013
Location: Phoenix AZ
Posts: 8
Default Re: jerryk

It does this every time. When you take your foot off the power it slows the cart as if the brake is on till you are almost to a stop then it seems to release. I dont have a problem with it as long i am not harming the cart. Again thanks for the response. I love this site, I read it every day.
jk1022 is offline   Reply With Quote
Unread 05-08-2014, 07:51 PM   #6
Gone Wild
 
CartTrader's Avatar
Club Car
 
Join Date: Aug 2008
Location: Ohio-In Summer, Central Florida-In winter
Posts: 887
Default Re: jerryk

Quote:
Originally Posted by jk1022 View Post
It does this every time. When you take your foot off the power it slows the cart as if the brake is on till you are almost to a stop then it seems to release. I dont have a problem with it as long i am not harming the cart. Again thanks for the response. I love this site, I read it every day.
No. it is fine. That is the regen braking in your cart...perfectly normal! Hard to get used to after driving a standard non-regen golf cart.

CartTrader
CartTrader is offline   Reply With Quote
Unread 05-09-2014, 10:39 AM   #7
Gone Wild
Club Car
 
Join Date: Sep 2012
Location: Alberta - Canada
Posts: 996
Default Re: jerryk

While helping a friend who bought a Precedent (2009 IQ, I think) from a Mountain Golf Course, he noticed that the Regen braking was programmed for "maximum" braking. It was pretty severe and really seemed aggressive when taking his foot off the accelerator from top speed. He took his controller in for re-programming and had it reduced to a much milder braking setting. Made a big difference. See this thread discussing the feature.
joesam is offline   Reply With Quote
Reply

Tags
2010 precedent, motor help
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes



All times are GMT -5. The time now is 08:13 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.