lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-16-2014, 02:29 PM   #1
Crazy Buggy Wild !!
 
InVision's Avatar
Club Car
 
Join Date: Mar 2014
Location: Destin, Florida
Posts: 543
Default Strange problem with turn signals

I decided to test out the complete wiring harness for my CC 2003 DS 48V cart before installing. Hooked up the entire setup horn, cig lighter, lights, turn signals, flashers, brake light, etc on garage floor. I hooked up a Trolling Motor 12V battery and was please to find every single thing hooked perfectly until I tested the headlights. When I turned on headlights the turn signals no longer worked. Everything else including the flashers still works.

Ok I must admit that I triple checked every wire and all is hooked up according to wire diagram. I have no clue.

Any advise will be greatly appreciated.

M
Attached Images
File Type: jpg photo3.JPG (874.3 KB, 0 views)
InVision is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-16-2014, 03:01 PM   #2
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,981
Default Re: Strange problem with turn signals

Your tail lights are probably hooked up wrong. I'll be your headlights/running light switch is wired to the brake light element on the tail lights and it's interfering with the turn signals. Take a picture of the back of your tail light and post it.
TahoeDawgZ71 is offline   Reply With Quote
Unread 05-16-2014, 03:14 PM   #3
Crazy Buggy Wild !!
 
InVision's Avatar
Club Car
 
Join Date: Mar 2014
Location: Destin, Florida
Posts: 543
Default Re: Strange problem with turn signals

First photo is drivers side tail light. Second is passenger side tail light.

White is ground, red is brake/turn and black is running lights. LED Tail Lights.

Thank you Sir !!

M
Attached Images
File Type: jpg photo 2.JPG (119.3 KB, 0 views)
File Type: jpg photo.JPG (135.3 KB, 0 views)
File Type: jpg p-1119-0970WHp7.jpg (363.2 KB, 0 views)
InVision is offline   Reply With Quote
Unread 05-16-2014, 03:53 PM   #4
Crazy Buggy Wild !!
 
InVision's Avatar
Club Car
 
Join Date: Mar 2014
Location: Destin, Florida
Posts: 543
Default Re: Strange problem with turn signals

Found the problem. Thanks All !!

M

PS - OOPS the content got left off... Sorry

The marine battery was at 12.34v. I charged it up to 12.75 and all works.

Thanks,

M
InVision is offline   Reply With Quote
Unread 05-16-2014, 04:13 PM   #5
Cave Dweller
 
Swan's Avatar
Club Car
 
Join Date: Apr 2013
Location: Always On The Move
Posts: 6,730
Default Re: Strange problem with turn signals

what was it ?
Swan is offline   Reply With Quote
Unread 05-16-2014, 04:21 PM   #6
Not here yet
 
branson's Avatar
E-Z-GO
 
Join Date: Sep 2013
Location: jupiter florida
Posts: 495
Default Re: Strange problem with turn signals

that's what you get for trying to test it out first. a headache and a dead battery
branson is offline   Reply With Quote
Unread 05-16-2014, 04:33 PM   #7
Crazy Buggy Wild !!
 
InVision's Avatar
Club Car
 
Join Date: Mar 2014
Location: Destin, Florida
Posts: 543
Default Re: Strange problem with turn signals

I did check the battery. It was 12.75 when I started. It wasn't till I put a volt meter on it while the Halogen Bulbs where on that I found the problem. As far as testing it out, with some of troubles I have heard about with the China harnesses I figured it would be best to know before installing so I could return if necessary.

M
InVision is offline   Reply With Quote
Unread 05-18-2014, 03:40 PM   #8
Crazy Buggy Wild !!
 
InVision's Avatar
Club Car
 
Join Date: Mar 2014
Location: Destin, Florida
Posts: 543
Default Re: Strange problem with turn signals

Well I installed the wiring harness. All works with a couple of small issues. Still have some kind of low voltage problem with the Halogen headlights turned on. If cart batteries are fully charged works fine with lights on. If batteries are below 50.1v then the turn signals do not work with the lights on. The Halogen bulbs take a tremendous amount of power. Probably a good excuse to get a set of LED headlights. One big improvement is the horn. The horn they sent me must be 120db or better. I mean EXTREMELY LOUD. The simple brake light switch I had also worked very well with the harness. There is one more annoying problem is that the drivers side turn signal does not light up on the control when on. The passengers side works fine? Puzzling because it bench check fine before I installed on cart.

Thanks All.

M
InVision is offline   Reply With Quote
Unread 05-18-2014, 06:10 PM   #9
Crazy Buggy Wild !!
 
InVision's Avatar
Club Car
 
Join Date: Mar 2014
Location: Destin, Florida
Posts: 543
Default Re: Strange problem with turn signals

Ok I have an update on issues. If my brake light is on the hazard flashers don't work. Drivers side control turn signals don't show on control, signals are working fine. Passengers side work fine. I am starting to believe I have a bad turn signal control. Any help would be greatly appreciated.

M
InVision is offline   Reply With Quote
Unread 05-18-2014, 06:54 PM   #10
Gone Wild
 
Doctord's Avatar
E-Z-GO
 
Join Date: May 2012
Location: Dimondale, MI
Posts: 177
Default Re: Strange problem with turn signals

I had just about the same issue on mine, I discovered that the wire to the lamp inside the turn signal housing, was being pulled too tight when I used the left turn signal, the lights would blink, but the indicator sometimes would not!
Doctord is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
New turn signals Gas EZGO
turn signals Gas EZGO
Turn signals Electric Club Car
Turn signals...again Electric EZGO
turn signals Gas Yamaha


All times are GMT -5. The time now is 05:00 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.