lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-02-2014, 01:34 PM   #1
Not Yet Wild
Club Car
 
Join Date: May 2014
Location: north texas
Posts: 17
Question club car not working

I have a 1998 club car DS and it has slowly progressed In my issue and is now not at all working! It started off as me flooring the go pedal and the golf cart going for a second and then stops completely and I can then slowly press the go pedal and it will run fine agai immediately. Then, it would do the same and the time it takes before it will run again continues to grow and now it doesn't do anything at all. Solenoid clicks every time and batteries are charged. A trusted golf cart mechanic said it sounds like an Mcor but I have a vglide and no mcor.

I have checked the v-glide and the wioer arm is not worn.
I hear the vglide click when I hit the go pedal
I have voltage and hear a click in solenoid when gas pedal is hit
I have 49volts running from the negative post on 5th battery to positive on 1st battery.

I am lost. What else do I check at this point??
cam_bates99 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-02-2014, 09:44 PM   #2
Epb
Gone Wild
Club Car
 
Join Date: Mar 2012
Location: Katy, Tx
Posts: 1,019
Default Re: club car not working

Batteries load tested good? All wire connections clean and tight? No corrosion buildup under the cables(bulging)? Checked wiring diagram?
The other thing you can consider is pulling motor and check brushes. If it slowly got worse and all else is good then I go to mechanicals. Rear end full? You have "resistance" somewhere in the system.
Epb is offline   Reply With Quote
Unread 06-02-2014, 09:55 PM   #3
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,975
Default Re: club car not working

Did you mean to say neg on the 5th battery, or was that a typo. 49 volts is just 60 to 70 % charge.
mrgolf is online now   Reply With Quote
Unread 06-03-2014, 12:49 PM   #4
Not Yet Wild
Club Car
 
Join Date: May 2014
Location: north texas
Posts: 17
Default Re: club car not working

Everything with batteries seemed fine. There may be a little corrosion because my monthly battery maintenance is due. I will check the motor. I will refer to the battery diagram when I get home but if it was running fine before then wire misplacement shouldnt be the problem considering I never moved them.
cam_bates99 is offline   Reply With Quote
Reply

Tags
1998, club car
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2000 club car obc not working Electric Club Car
81 Club Car stopped working Electric Club Car
94 club car quit working Electric Club Car
04 Club Car stopped working PLEASE HELP! Electric Club Car
Club Car Charger Not Working Electric Club Car


All times are GMT -5. The time now is 11:11 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.