lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-03-2014, 11:40 AM   #1
Not Yet Wild
 
Join Date: May 2011
Posts: 23
Default Speed sensor or MCOR???

I have a 2004 club car precedent. When I push the go pedal, the cart takes off like normal at a quick pace. After a half minute or so the cart slows down to a really slow pace. I can release the pedal and start over and the cart takes off like normal, and then slows down again. The cart will continue to take off normal when pedal is released and slow again several times and then it will just go slow all the time, even if pedal is released and depressed again. I read and get so many varied opinions, so I guess I'm just not sure. The cart is at the cabin and I don't have a dealer close by to check it out. I was hoping to make and educated guess and try brining the part with and hopefully get lucky. If anyone can chime in, it would be much appreciated.
PQ0327
brivy1900 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-03-2014, 11:55 AM   #2
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,025
Default Re: Speed sensor or MCOR???

Go to the sticky threads at the top of the page and do the speed sensor roll test.
TahoeDawgZ71 is offline   Reply With Quote
Unread 06-03-2014, 11:57 AM   #3
Not Yet Wild
 
Join Date: May 2011
Posts: 23
Default Re: Speed sensor or MCOR???

Quote:
Originally Posted by TahoeDawgZ71 View Post
Go to the sticky threads at the top of the page and do the speed sensor roll test.
Would love too, but the cart is 3 hours away and im trying to see if I can figure it out based on others experience.
brivy1900 is offline   Reply With Quote
Unread 06-03-2014, 04:09 PM   #4
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,025
Default Re: Speed sensor or MCOR???

Based on experience, it sounds more like a speed sensor than an MCOR, but I can't tell you for sure until you do the test.
TahoeDawgZ71 is offline   Reply With Quote
Unread 06-04-2014, 01:08 AM   #5
STEALTH 4X4
 
sunoco's Avatar
Club Car
 
Join Date: Sep 2011
Location: GA
Posts: 2,017
Default Re: Speed sensor or MCOR???

2003 Precedent?
sunoco is offline   Reply With Quote
Unread 06-04-2014, 06:45 AM   #6
DS Drivers Club Founder
 
CCFanatic's Avatar
Club Car
 
Join Date: Jul 2013
Location: Upstate NY
Posts: 3,409
Default Re: Speed sensor or MCOR???

Quote:
Originally Posted by sunoco View Post
2003 Precedent?
Yep, he has a proto-type.
CCFanatic is online now   Reply With Quote
Unread 06-12-2014, 05:05 PM   #7
Not Yet Wild
 
Join Date: May 2011
Posts: 23
Default Re: Speed sensor or MCOR???

Quote:
Originally Posted by TahoeDawgZ71 View Post
Go to the sticky threads at the top of the page and do the speed sensor roll test.
I did the rollaway test and there was no resistance and no beeps. I pulled the cap off and inspected the sensor I have the GE motor the flat sensor. The sensor or the magnet seems to look okay I didn't see any cracks and it looks pretty clean.can a sensor be bad even if upon inspection I do not see any cracks or chips? I'm really trying to figure out if this is a speed sensor issue or Namco reissue please help please advise I'm stuck in the northern woods of Minnesota.
does a picture of the sensor help at all? If I'm given an email address I can attach a picture.
brivy1900 is offline   Reply With Quote
Unread 06-12-2014, 05:23 PM   #8
Not Yet Wild
 
Join Date: Dec 2011
Location: westmemphis, Ar
Posts: 72
Default Re: Speed sensor or MCOR???

Speed sensor bad
birdleg is offline   Reply With Quote
Unread 06-12-2014, 05:25 PM   #9
Not Yet Wild
 
Join Date: Dec 2011
Location: westmemphis, Ar
Posts: 72
Default Re: Speed sensor or MCOR???

I replaced many that looked new. They just fail. I'm sure you slap one on and will be good to go. That part I believe is less than 60 bux
birdleg is offline   Reply With Quote
Unread 06-12-2014, 07:03 PM   #10
Not Yet Wild
 
Join Date: May 2011
Posts: 23
Default Re: Speed sensor or MCOR???

Quote:
Originally Posted by birdleg View Post
I replaced many that looked new. They just fail. I'm sure you slap one on and will be good to go. That part I believe is less than 60 bux
Whoa, 60 bucks...where???

Im hoping its not an mcor
brivy1900 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
MCOR? Speed Sensor? Controller? Cart Runs at half speed. Advice, please. Electric Club Car
08 precedent electric speed sensor problem. Cart starts at proper speed then slows . Electric Club Car
Speed Sensor ? Extreme DC!
Does the speed sensor affect reverse speed? Electric Club Car
Half speed, speed sensor problem?. Electric Club Car


All times are GMT -5. The time now is 04:15 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.