lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-17-2014, 09:06 AM   #1
Not Yet Wild
 
Join Date: Jun 2014
Posts: 1
Default electric club car not working after rebuild

Hello all first time posting please be kind.

I have a 2004 electric club car (48v) that we just had repainted. In the process of disassembly I removed the charging receptacle. this involved removing the positive lead off of the battery and a negative lead off of the back of the charging unit itself, there were two weather pack connections as well.
The cart sat for about a week but now when I reassembled everything and replaced the wires I get no power to the motor. As you probably know the club car will give the back up horn even if it's not moving but now the horn doesn't even work.
My ohm meter registers ~8volts per battery so I know they have a charge, the two weatherpack connectors are uniquely shaped so I know those are plugged in correctly.
Is there some sort of motor reset that I am unaware of?
Again, first post, first time cart owner.

Thanks for the consideration

Brad cohen
bradfnp is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-17-2014, 10:54 AM   #2
Gone Wild
 
Join Date: Jan 2012
Location: California
Posts: 267
Default Re: electric club car not working after rebuild

Hello and welcome

Go back to square one and check everything. Not sure which 04 CC you have
but here's a couple wiring diagrams to use.



PuttPutt is offline   Reply With Quote
Unread 06-17-2014, 12:20 PM   #3
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,063
Default Re: electric club car not working after rebuild

if you have a run/tow switch make sure it is in run
crash test dummy is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Electric club car stopped working 1998 Electric Club Car
1984 Electric Club Car Rebuild (power issues) Electric Club Car
2008 electric club car quit working Electric Club Car
Club Car Electric Stopped working Electric Club Car
Electric Club Car Stopped Working Electric Club Car


All times are GMT -5. The time now is 03:16 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.