lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-25-2008, 02:45 PM   #1
Not Yet Wild
Club Car
 
Join Date: Oct 2008
Posts: 3
Smile 2009 Club Car XRT850E Private Speed Mode Problem

Hello everyone, I am new to the community and this is my first post.

A few weeks ago I purchased a new 2009 Club Car XRT850E electric utilitity vehicle. This is the first golf cart that I have owned and it is also the first electric vehicle. So far I am very pleased with the XRT, but I have run into an issue that I hope someone in the community can help me with.

The XRT runs on the Club Car 48 volt IQ system and according to a GPS device I have attached the cart currently has a top speed of about 15.2 mph on flat ground (#3 speed setting). I purchased the #4 Private Speed Mode code (19.6 mph) from my local dealer and went to their shop to have the code installed today. The technician installing the code hooked up the IQ Display Module (IQDM) and appeared to successfully program in the code (the IQ module allowed him to select the #4 setting), but upon testing the cart the top speed had not changed from what it was before the #4 code was programmed in. After several tries at changing IQ settings and several more test runs including the technician and I driving up and down the road with the IQDM attached to make sure everything on the cart was working correctly we were still not able to achieve "Private Speed". We tried setting the speed code to the #1 and #2 settings and those slowed the cart down, but the #3 and #4 settings yield the exact same top speed (approx 15.2 mph on flat ground and even down hill).

The tech is stumped as to why Private Speed mode won't kick in and is going to contact Club Car on Monday to see what they have to say. Do any of you have any ideas? Is there a special technique to get this mode to work? The procedure the tech was using seemed to be hook up the IQDM, program in Code A, Code B, and Code C, and then flip the Tow/Run switch to the Tow position for a minute or so and then the IQDM would indicate that #4 was selected. During troubleshooting if the code was changed from #4 to #1, #2 or #3, then the #4 Private Speed Code would have to be re-input before the IQDM would allow selection of the #4 setting again.

Thank you in advance for any help you can provide.
XRT850E is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-27-2008, 11:10 AM   #2
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Smile Re: 2009 Club Car XRT850E Private Speed Mode Problem

Welcome to the group XRT850E !
Glad to see this post , not that I can help you !
But this is great information for future reference in case I ever get to the point when I can afford a new 2009 .

I'm sure some of the guys (dealers) here can help !

garry
GLEEMO is offline   Reply With Quote
Unread 10-28-2008, 07:11 AM   #3
Not Yet Wild
Club Car
 
Join Date: Oct 2008
Posts: 3
Default Re: 2009 Club Car XRT850E Private Speed Mode Problem

Thanks for the welcome. I'm headed back to the dealer today to give it another try. I'll post how things turn out.
XRT850E is offline   Reply With Quote
Unread 10-28-2008, 10:08 AM   #4
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: 2009 Club Car XRT850E Private Speed Mode Problem

Welcome to the forum XRT850E...................
rusty is offline   Reply With Quote
Unread 10-28-2008, 03:13 PM   #5
Not Yet Wild
Club Car
 
Join Date: Oct 2008
Posts: 3
Unhappy Re: 2009 Club Car XRT850E Private Speed Mode Problem

Thanks for the welcome, Rusty.

It turns out that Club Car does something at the factory to the controllers on the XRT850Eís to prevent speeds higher than what the #3 setting allows. I am told that this is because of the factory lift kit on the cart.

This didnít stop Club Car from going ahead and selling my controllerís unique #4 speed code to my local dealer so that they could sell it to me, though. The controller accepts the code and does indicate speed mode #4, but thanks to the extra factory tweak, the top speed of the cart remains as it is for setting #3.

It took two 60+ mile round trips to the dealer, multiple calls to Club Car, and many hours of my time before a Club Car regional sales rep finally figured out what the problem was and told my local dealer that the code never should have been sold to me in the first place. They refunded my money, but I still feel like Iíve been screwed. Especially since Club Car assured my local dealer that the code was correct and that it would work before they had me haul the cart back to the dealer the second time.

Venting complete. Thanks!
XRT850E is offline   Reply With Quote
Unread 10-28-2008, 06:13 PM   #6
steeplejack x
 
pggroves's Avatar
E-Z-GO
 
Join Date: Jan 2007
Location: Republic of Texas
Posts: 3,337
Default Re: 2009 Club Car XRT850E Private Speed Mode Problem

Glad you got it figured out.
Sounds like a liability issue from Club Car's perspective.
**** lawyers anyway!!!!!
pggroves is offline   Reply With Quote
Unread 10-28-2008, 06:59 PM   #7
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: 2009 Club Car XRT850E Private Speed Mode Problem

I feel your pain, sounds like a horror story. I assume it has something to do with the cart still being under warrenty. Looks like there is a dis-advantage in buying NEW :))

Thanks for the sharing
GLEEMO is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Good deal on 2009 E-Z-GO Heritage's Gas golf carts
2000 PDS...limp home mode problem. Electric EZGO
94 ezgo speed problem Electric EZGO
2002 EZGO PDS speed problem Electric EZGO
speed problem Electric EZGO


All times are GMT -5. The time now is 10:20 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.