lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-11-2014, 05:26 PM   #1
Not Yet Wild
Club Car
 
Join Date: Jun 2014
Location: Indiana
Posts: 7
Default 48v ds wired incorrectly?

I have all the cosmetics done on my cart and now I'm turning my attention to the running of the cart. It's a 2000 48v. Looking at wiring diagrams I think the previous owner has it wrong I have the 2 cables to the controller coming from the negative on battery 6 and battery 1. I've had the cart about a month now and it has ran and seemed to be charging. Went to charge it today and the relay clicked but the charger doesn't move from zero. Not sure if the wiring has the charger not working. The charger would never go above 15amps a never would kick off. Told by previous owner he repaired the charger and it quit automatically shutting off. So I've just been charging it all day and pulling the plug at night after using the cart. Hope someone can point me in some direction.

Here is a iPhone picture of the batteries
Attached Images
File Type: jpg image.jpg (176.3 KB, 0 views)
Bkessler is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-11-2014, 06:22 PM   #2
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: 48v ds wired incorrectly?

My advise would be to buy a new charger or at least put some kind of timer on the one you got. Second would be to check the water levels in your batteries. You may have overcharged it out. What's up with the top left battery. One post doesn't appear to be connected to anything.
Also if it ran OK before I would think the wiring is ok. Don't go randomly changing wires.
jjance is offline   Reply With Quote
Unread 07-11-2014, 06:26 PM   #3
DS Drivers Club Founder
 
CCFanatic's Avatar
Club Car
 
Join Date: Jul 2013
Location: Upstate NY
Posts: 3,408
Default Re: 48v ds wired incorrectly?

Quote:
Originally Posted by Bkessler View Post
I have all the cosmetics done on my cart and now I'm turning my attention to the running of the cart. It's a 2000 48v. Looking at wiring diagrams I think the previous owner has it wrong I have the 2 cables to the controller coming from the negative on battery 6 and battery 1. I've had the cart about a month now and it has ran and seemed to be charging. Went to charge it today and the relay clicked but the charger doesn't move from zero. Not sure if the wiring has the charger not working. The charger would never go above 15amps a never would kick off. Told by previous owner he repaired the charger and it quit automatically shutting off. So I've just been charging it all day and pulling the plug at night after using the cart. Hope someone can point me in some direction.

Here is a iPhone picture of the batteries
Here is your problem. You have four 8 volt batteries, and the two on the far right side of the picture are 6 volt batteries. The cart is designed to run on 48v. You only have 44v worth of batteries.
CCFanatic is offline   Reply With Quote
Unread 07-11-2014, 06:36 PM   #4
Gone Wild
 
DIRTPIT HC's Avatar
Club Car
 
Join Date: Jun 2014
Location: Brandon MS
Posts: 309
Default Re: 48v ds wired incorrectly?

I think the picture just has the 4th water wells not visible. If your cart is a CC I believe the pic below is how your cart should be wired. The wiring in the pic above does not appear to be right.
Attached Images
File Type: jpg 48volt.jpg (72.4 KB, 0 views)
DIRTPIT HC is offline   Reply With Quote
Unread 07-11-2014, 06:42 PM   #5
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,974
Default Re: 48v ds wired incorrectly?

The number 1 battery does not have a wire on neg post. It looks like the pos from # 2 is going to pos on #1, it should go to neg of #1. The two on the right seem to only have three caps. I suspect that is the view the phone had for the photo. The other caps are likely out of frame.
mrgolf is offline   Reply With Quote
Unread 07-11-2014, 07:47 PM   #6
Not Yet Wild
Club Car
 
Join Date: Jun 2014
Location: Indiana
Posts: 7
Default Re: 48v ds wired incorrectly?

Right now battery 1 has nothing going or coming from the positive. Then from the negative on battery 1 it goes to the positive on 2. But also from the negative on 1 it's running to the controller I believe. So battery 1 and 6 both have negatives going back to the controller. I also filled the cells to above the metal in all batteries that were low with distilled water Tuesday. When I was checking them all. Also yes they are all 8v batteries just a bad picture angle.

I didn't think the motor could run with power coming from 2 negatives. That I guess is question 1 as to why it's working like that. Question 2 would be the fact that it was charging fine for a month but then quit out of the blue this afternoon. After searching I'm wondering if the batteries are to low and it isn't meeting the threshold for the charger causing it to not kick on. I hear the charger click after about 5 seconds but then it doesn't do anything. I'm assuming it's the relay that I hear. Thanks again everyone for helping me with the trouble shooting, the wife is already beginning her I told you do routine when she asked what I was working on. So the quicker I figure it out the better it is for my ear drums. Lol
Here should be a better picture of batteries 1-3. Top left is battery 1, picture taken from driver side of the cart
Attached Images
File Type: jpg image.jpg (180.9 KB, 0 views)
Bkessler is offline   Reply With Quote
Unread 07-11-2014, 08:07 PM   #7
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: 48v ds wired incorrectly?

After looking at your new picture it looks like the battery with only one terminal connected is wired wrong. You need to remove the black wire from the positive terminal and connect it to the unused terminal. Be sure it is marked Neg or -. What you did is remove that last battery from the pack. You should be reading about 8v or more low on the battery pack. PS I know that feeling about I told you so.
jjance is offline   Reply With Quote
Unread 07-11-2014, 08:09 PM   #8
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,974
Default Re: 48v ds wired incorrectly?

You only have five batteries wired into the pack. The one with the red cable is not doing anything but holding the cables as a connection point. The red cable need a new or better end put on it. Connect it to the pos on that battery. Connect the black cable that is on that post to the neg post of that battery. The other end should go to the pos of the battery next to it, and on that way till you have the last neg cable going to the controller b- through the obc.
mrgolf is offline   Reply With Quote
Unread 07-11-2014, 08:15 PM   #9
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: 48v ds wired incorrectly?

One more thing your batteries are probably shot. Sticker date says 4/09. Plus they are Energizers.
jjance is offline   Reply With Quote
Unread 07-11-2014, 08:55 PM   #10
Not Yet Wild
Club Car
 
Join Date: Jun 2014
Location: Indiana
Posts: 7
Default Re: 48v ds wired incorrectly?

Thanks you all. I figured the red was suppose to be going to the positive on battery 1 but didn't want to mess with it until I knew I wasn't looking at it wrong. Also figured 5 years out of the batteries was about all she wrote on them. Guess it's time to order the new batteries and try to make this thing not so slow. And a charger from the sound of it may need replaced as well. This will be an expensive I told you so. Guess a new purse and shoes will probably be in my near future as well. Thanks again everyone. I'll at least include a picture of the finished pretty side of the cart
Attached Images
File Type: jpg image.jpg (160.9 KB, 0 views)
Bkessler is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
97 Voltage reducer. Wired hot? Electric Club Car
Is this wired correctly? Electric EZGO
Batteries spark after being hooked up incorrectly Electric EZGO
crossed wired Electric EZGO
need wired Gas EZGO


All times are GMT -5. The time now is 01:05 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.