lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-20-2014, 09:27 PM   #1
DC4
Not Yet Wild
 
Join Date: Jul 2014
Posts: 15
Default club car running slow with new batteries

Bought use club car, cheap,with 2006 batteries but only movement was sputtering. Did the epson salt trick to the batteries and cart worked great. Good speed. After a few uses batteries didn't hold charge very well, cord would get very hot with charge and water needed adding after every charge. Cart had slowed down and started sputtering again. Decided to get new batteries 6, T-875 batteries. Cord still getting hot and cart not going as fast as it had been going with old batteries. After reading posts I realized the heating was resistance and I cleaned the connections behind the F/R. Cord not heating anymore. New batteries working well first few times cart is used and charged after each use. Used cart this weekend and it moved very slow, with full charge, and then quickly started sputtering. Could get it to barely move with peddle half way down. Charged batteries started at 20 amps and within 30 min was down to 5. Tried cart again and same thing, very slow and sputtering after 1 short block. We didn't change cables with new batteries or any wires.
Any ideas what has happened. Thank you!
2001 club car with lift, 48 volt, 6 new Batteries, model# 5bc59jbs6360
DC4 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-20-2014, 09:37 PM   #2
Gone Wild
 
sportcoupe's Avatar
E-Z-GO
 
Join Date: Sep 2012
Location: Savannah, GA
Posts: 2,760
Default Re: club car running slow with new batteries

Quote:
Originally Posted by DC4 View Post
Charged batteries started at 20 volt and within 30 min was down to 5.
That makes no sense. If a 48v carts battery pack reads 20v then 5v you have completely killed the batteries.

What is the pack voltage and individual battery voltages after 12 hours off the charger?

Also, you posted club car questions in the ezgo forum. Honest mistake I'm sure. Maybe a mod will move this thread.
sportcoupe is offline   Reply With Quote
Unread 07-20-2014, 10:31 PM   #3
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,066
Default Re: club car running slow with new batteries

Quote:
Originally Posted by sportcoupe View Post
That makes no sense. If a 48v carts battery pack reads 20v then 5v you have completely killed the batteries.

What is the pack voltage and individual battery voltages after 12 hours off the charger?

Also, you posted club car questions in the ezgo forum. Honest mistake I'm sure. Maybe a mod will move this thread.
he means amps

make sure you wired it correctly . look in the CLUB CAR area for your diagram
crash test dummy is online now   Reply With Quote
Unread 07-20-2014, 10:50 PM   #4
Moderator
 
rib33024's Avatar
E-Z-GO
 
Join Date: Apr 2009
Location: FT Lauderdale FL.
Posts: 13,169
Default Re: club car running slow with new batteries

Moved
rib33024 is offline   Reply With Quote
Unread 07-20-2014, 10:54 PM   #5
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,066
Default Re: club car running slow with new batteries



you da man RIB !!
crash test dummy is online now   Reply With Quote
Unread 07-20-2014, 11:55 PM   #6
DC4
Not Yet Wild
 
Join Date: Jul 2014
Posts: 15
Default Re: club car running slow with new batteries

Thanks I'll recheck the cable wiring.
DC4 is offline   Reply With Quote
Unread 07-22-2014, 07:18 PM   #7
DC4
Not Yet Wild
 
Join Date: Jul 2014
Posts: 15
Default Re: club car running slow with new batteries

Wiring is good. Will change cables next week and see if that helps.
DC4 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2002 Club Car DS running slow Electric Club Car
2003 Club Car running very slow Electric Club Car
Club Cart Running Slow Lifted Golf Carts
Running Slow With New Batteries Electric Club Car
Club car running slow Electric Club Car


All times are GMT -5. The time now is 02:46 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.