lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-21-2014, 07:09 PM   #1
Not Yet Wild
Club Car
 
Join Date: Jul 2014
Posts: 12
Default Seems to skip "gears"

Hello.

I have a 1986 ds club car

We have an issue when pressing the pedal.

It sounds like a bunch of clicks, I can hear about 5 clicks.

Anyways. In fwd and rev the issue is the same.

When we try to accelerate, we here a click, and the cart will crawl, then another click, and yet another, then on the fourth it will dart fwd or backward, and lastly the fifth, will speed up further.

Do I need to replace all or some of the solenoids, or other parts?

I think the pics are of the solenoids in question?


Many thanks

Paul
Paulzy123 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-22-2014, 07:05 AM   #2
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: Seems to skip "gears"

. . . could also be bad speed switches (the clicking sound you hear) . . . find the small box on the driver's side in the bottom of the battery compartment with wires that run to the solenoids . . . your switches are in there . . . try cleaning them and checking/tightening connections . . . start there first . . .
Stevegrmich is offline   Reply With Quote
Unread 07-22-2014, 07:42 PM   #3
Not Yet Wild
Club Car
 
Join Date: Jul 2014
Posts: 12
Default

Will do.

Thx.

I have a multimeter, are these switches easy to test?


Paul
Paulzy123 is offline   Reply With Quote
Unread 08-06-2014, 08:32 PM   #4
Not Yet Wild
Club Car
 
Join Date: Jul 2014
Posts: 12
Default

Checked all the mini switches, all function properly.

The solenoid does actuate, however when I put a volt meter across the motor, when the solenoid in question actuates the voltage does not jump as expected.

I've ordered a new solenoid.


Paul
Paulzy123 is offline   Reply With Quote
Unread 08-08-2014, 08:28 PM   #5
Gone Wild
 
scotter's Avatar
Club Car
 
Join Date: Jun 2013
Location: San Clemente, CA
Posts: 259
Default Re: Seems to skip "gears"

Most folks find that replacing all the solenoids at same time reduces repetitive repairing. Just a thought.
scotter is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Club Car belt/clutch won't "change", as stuck in "low" gear Gas Club Car
Why "Carbon Fiber" "Wood grain" and Diamond Plated? Gas EZGO
What kind of offset is my EZGO RXV w/Jakes 6" Lift Kit and 2" spacer rear and 1" back Lifted Golf Carts
Installed 15:1 torque gears need Help "soon" please Electric EZGO
limo stock tire height " clutch and gears?" Gas EZGO


All times are GMT -5. The time now is 12:10 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.