lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-28-2014, 01:04 AM   #1
Not Yet Wild
 
loneranger404's Avatar
E-Z-GO
 
Join Date: Mar 2011
Location: S.C.
Posts: 41
Default Is my Reducer going bad?

I have a 04 DS CC and three years ago a Blackhawk reducer was installed along with a Blue Sea Fuse Block with neg bus and everything was fine until now. When the lights are turned on, they go off when I accelerate and will come back on when I let off the pedal a little. I was wondering if the reducer is going bad or could it be something else? Any suggestions would be greatly appreciated.
loneranger404 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-28-2014, 09:43 AM   #2
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,068
Default Re: Is my Reducer going bad?

Connect a meter to your pack and see what the voltage drops to when the lights go out. You may have a bad battery
scottyb is offline   Reply With Quote
Unread 07-28-2014, 08:05 PM   #3
Not Yet Wild
 
loneranger404's Avatar
E-Z-GO
 
Join Date: Mar 2011
Location: S.C.
Posts: 41
Default Re: Is my Reducer going bad?

There is no lost of power/acceleration, it just effects the lights, it's the darnedest thing.
loneranger404 is offline   Reply With Quote
Unread 07-28-2014, 08:50 PM   #4
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,068
Default Re: Is my Reducer going bad?

Just effects the lights ..... under load?
scottyb is offline   Reply With Quote
Unread 07-28-2014, 09:30 PM   #5
Not Yet Wild
 
loneranger404's Avatar
E-Z-GO
 
Join Date: Mar 2011
Location: S.C.
Posts: 41
Default Re: Is my Reducer going bad?

Correct. Lights go out when I accelerate, once leveled off they come back on.
loneranger404 is offline   Reply With Quote
Unread 07-29-2014, 07:52 AM   #6
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: Is my Reducer going bad?

. . . when was last time you cleaned/checked reducer's connections at battery terminals? . . . . just a thought . . .
Stevegrmich is offline   Reply With Quote
Unread 07-29-2014, 12:52 PM   #7
Not Yet Wild
 
loneranger404's Avatar
E-Z-GO
 
Join Date: Mar 2011
Location: S.C.
Posts: 41
Default Re: Is my Reducer going bad?

They are clean. I'm leaning toward the reducer going bad but I don't know what the tell-tell signs are.
loneranger404 is offline   Reply With Quote
Unread 07-30-2014, 02:22 AM   #8
Not Yet Wild
 
loneranger404's Avatar
E-Z-GO
 
Join Date: Mar 2011
Location: S.C.
Posts: 41
Default Re: Is my Reducer going bad?

Am I the only only one that has experience this?
loneranger404 is offline   Reply With Quote
Unread 07-30-2014, 05:30 AM   #9
Not here yet
 
branson's Avatar
E-Z-GO
 
Join Date: Sep 2013
Location: jupiter florida
Posts: 495
Default Re: Is my Reducer going bad?

Quote:
Originally Posted by loneranger404 View Post
They are clean. I'm leaning toward the reducer going bad but I don't know what the tell-tell signs are.
terminals can look clean on the outside and still be a poor connection. have you checked the voltage with a meter? it is going to be difficult to tell what the problem is without some real data.
branson is offline   Reply With Quote
Unread 07-30-2014, 06:15 AM   #10
Gone Wild
 
teecro's Avatar
Club Car
 
Join Date: Jun 2014
Location: Sunset Bay, TN
Posts: 2,214
Default Re: Is my Reducer going bad?

Quote:
Originally Posted by loneranger404 View Post
There is no lost of power/acceleration, it just effects the lights, it's the darnedest thing.
If your voltage is dropping below a minimum number during acceleration your reducer could very well be dropping out for that reason; and a battery or batteries GOING bad could be causing this... This is why if you do not have a voltage meter you should install one so that you actually know what your pack voltage is.... And as asked before are your cable connections clean and tight and has your water levels be checked recently? Start from the beginning with the basics....
teecro is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Dc reducer in a pds Electric EZGO
best buy for 48v dc reducer Electric Yamaha
48V to 12V reducer necessary? Electric Club Car
48v reducer to 12v Electric Yamaha
Reducer HELP Electric Club Car


All times are GMT -5. The time now is 11:07 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.