lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-30-2014, 10:20 AM   #1
Not Yet Wild
 
Join Date: Jul 2014
Posts: 15
Default 2005 48V Club Car issues (help!) newbie

So I purchased a 2005 Club Car DS from someone and the batteries were bad. I replaced all 6 batteries with NEW Trojans. The cart at take off seems fast but doesnt feel like to goes thru all the gears if you know what I mean. The top end sucks! My dad has a 2001 Club Car and runs off leaving me behind.

Now there is a white wire coming off the solenoid that I was not sure where it went. It would not move tho until I connected it to the power on one of the batteries...

There is also a blue wire dangling not sure where it goes either... thanks guys, any help would be greatly appreciated...

I have called myself looking at a wiring diagram (from a manual I found online) but still cannot figure it out..

I also think the brakes may be sticking a little. Reason I say this is because in tow it is very hard to push...even when the batteries were out of it
Attached Images
File Type: jpg 20140730_074500.jpg (193.3 KB, 0 views)
File Type: jpg 20140730_074455.jpg (209.9 KB, 0 views)
File Type: jpg 20140730_074425.jpg (174.3 KB, 0 views)
File Type: jpg 20140730_074408.jpg (199.3 KB, 0 views)
File Type: jpg 20140730_074516.jpg (197.8 KB, 0 views)
freemurray is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-01-2014, 11:40 PM   #2
Not Yet Wild
 
Join Date: Jul 2014
Posts: 15
Default Re: 2005 48V Club Car issues (help!) newbie

so I figured it out... the blue and white wire that was dangling went to the left side of the sylenoid... that white wire was not suppose to be there
freemurray is offline   Reply With Quote
Unread 08-06-2014, 07:18 PM   #3
Not Yet Wild
 
Join Date: Jul 2014
Posts: 15
Default Re: 2005 48V Club Car issues (help!) newbie

and my speed sensor was bad. the magnet had a slight crack in it.... its good and fast now...no limp mode
freemurray is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Newbie with 2005 Club Car DS wanting to upgrade for hunting Electric Club Car
2005 club car gas running issues Gas Club Car
Battery/Charger Issues with 2005 Precedent Electric Club Car
2005 Precedent issues... Electric Club Car
ez go shutter issues help! newbie! Electric EZGO


All times are GMT -5. The time now is 06:00 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.