lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-11-2014, 10:16 AM   #1
Not Yet Wild
 
Join Date: Aug 2014
Posts: 1
Default 91 Club Car

We have 91 club car. we installed new batteries and now the car goes VERY slow forward and will not go in reverse. It beeps when moved to reverse but nothing happens. Installed new solenoid switch too. Any ideas?
Thanks, Rodney
cbraddy is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-11-2014, 07:57 PM   #2
Gone Wild
 
scotter's Avatar
Club Car
 
Join Date: Jun 2013
Location: San Clemente, CA
Posts: 259
Default Re: 91 Club Car

look at the sticky for wiring diagrams for your year cart and verify your cables/wiring are connected correctly. Sounds like you have something mis-wired.
scotter is offline   Reply With Quote
Unread 08-11-2014, 09:14 PM   #3
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,058
Default Re: 91 Club Car


9 out of 10 times its a wiring problem...
what you describe sounds like you got the forward cable (red) on the reverse spot on batteries , where the reverse cable (green) goes

crash test dummy is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes



All times are GMT -5. The time now is 07:31 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.