lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-27-2014, 09:54 AM   #1
Not Yet Wild
 
Join Date: Aug 2014
Posts: 2
Default New batteries, no lights and no click.

Hi Guys, seems like a lot of good info here. I have searched a lot of threads but have not come across anyone who posted same issues I am having.

We have a 2003 CC. About a month ago we installed new batteries. It ran well up until a few days ago. Basically it stopped going. Have tried resetting the OCS with no luck. Actually the procedure I read said that once I go into reset mode the reverse buzzer should sound. That never happened so I put the negative cable back on and looked around for other issues...

Current issues are as follows; Cart does not go forward or reverse, all batteries appear to have a full charge. Close or at 9v each, lights do not come on, 1 light comes on for battery indicater(far right one), If I jiggle the ignition switch the light on the indicater gets brighter but still lights will not turn on. No clicking from solenoid either. Have checked fuses in main compartment but have not found any blown.

Any advice, ideas would be appreciatted. Thanks!!
windguy is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-28-2014, 06:45 AM   #2
Not Yet Wild
 
Join Date: Aug 2014
Posts: 2
Default Re: New batteries, no lights and no click.

UPDATE: after thinking about the reset procedure not working and the battery indicator light fluctuating if I twist the ignition I decided to take a look at the ignition switch after close review I noticed one of the terminals was ever so slightly melted. Have ordered a new one on-line for $17. Should be here in a few days.

Will update progress accordingly.

Thanks, Bill
windguy is offline   Reply With Quote
Unread 08-28-2014, 02:09 PM   #3
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: New batteries, no lights and no click.

I was going to suggest replacing the switch. I believe you're on the right track windguy.
jjance is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
'85 G2E No movement, click or buzz. Batteries good. Electric Yamaha
86-89 Club car won't go (New batteries) No click just nothing! Electric Club Car
2002 new batteries and lights are dim Electric EZGO
How to wire 12v lights on two 6v batteries? Electric EZGO
No pedal click but have new batteries in it Electric EZGO


All times are GMT -5. The time now is 03:17 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.