lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-04-2014, 04:36 PM   #1
Not Yet Wild
 
Join Date: Sep 2009
Posts: 45
Default 2007 CC batts flat, no charge

Hi Guys

Need a little help please, I went on vacation for nearly a month and when I got back my President had gone flat although I had the charger plugged in the whole time and it was charged nicely before I left now all voltage gone from the batts with the battery meter pegged at empty. I have plugged in the charger again but its not charging or clicking on so I am thinking it might be the charger but not sure how I can tell for sure.

Can anyone please offer any advice what I can do from here please, I am pretty handy with a multi-meter if that helps.

Thanks

Stuart
outatime is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-04-2014, 04:42 PM   #2
Gone Wild
 
tjequip's Avatar
Club Car
 
Join Date: Oct 2009
Location: Alva Fla
Posts: 607
Default Re: 2007 CC batts flat, no charge

do you have 12 volt batteries?
tjequip is offline   Reply With Quote
Unread 09-04-2014, 06:29 PM   #3
Gone Wild
Yamaha
 
Join Date: May 2012
Location: Rio Verde, Az
Posts: 2,681
Default Re: 2007 CC batts flat, no charge

You need to get a charge back into them before the charger can work. Use an auto battery charger on individual batteries. If they are 8 volt batteries, only charge them enough to get the voltage up over 8 V. If they are 6 volt batteries, you can charge two in series with a 12V charger. If they are 12V batteries, then the 12V charger will charge them nicely.
Volt_Ampere is offline   Reply With Quote
Unread 09-04-2014, 06:52 PM   #4
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: 2007 CC batts flat, no charge

I suspect something was left turned on in your cart. I used to leave mine for months and get in and drive right off when I got back. And the charger wasn't plugged in.
jjance is offline   Reply With Quote
Unread 09-04-2014, 06:59 PM   #5
Not Yet Wild
 
Join Date: Sep 2009
Posts: 45
Default Re: 2007 CC batts flat, no charge

Thanks guys, yes they are four 12v batteries so I have disconnected the cables and put the car charger on them, will update you when I have got all four charged and plug the charger back in. Thanks again.
outatime is offline   Reply With Quote
Unread 09-04-2014, 07:56 PM   #6
Gone Wild
 
sportcoupe's Avatar
E-Z-GO
 
Join Date: Sep 2012
Location: Savannah, GA
Posts: 2,760
Default Re: 2007 CC batts flat, no charge

For future reference you don't need to disconnect the cart cables from the batteries to use a 12v charger on individual batteries.
sportcoupe is offline   Reply With Quote
Unread 09-05-2014, 11:22 AM   #7
Not Yet Wild
 
Join Date: Sep 2009
Posts: 45
Default Re: 2007 CC batts flat, no charge

Thx guys, anyone have any issues with a vector battery charger, its one of those diagnostic ones and it charges for a bit then gives me an error about a cell short circuit and turns off. Does it on all four, maybe I need a basic charger.
outatime is offline   Reply With Quote
Unread 09-05-2014, 11:50 AM   #8
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: 2007 CC batts flat, no charge

Did you check the water level?
jjance is offline   Reply With Quote
Unread 09-05-2014, 12:45 PM   #9
Not Yet Wild
 
Join Date: Sep 2009
Posts: 45
Default Re: 2007 CC batts flat, no charge

Yep water level is fine on all batts, when I originally found everything dead I thought I had burnt them out but they all had water.
outatime is offline   Reply With Quote
Unread 09-05-2014, 01:21 PM   #10
Gone Wild
Yamaha
 
Join Date: May 2012
Location: Rio Verde, Az
Posts: 2,681
Default Re: 2007 CC batts flat, no charge

If they were flat dead, your charger may think they have a shorted cell and not charge them. Tray a basic Auto Battery Charger.
Volt_Ampere is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Total Charge vs. Toasted Batts.. Which is it Electric EZGO
2007 Precedent won't charge Electric Club Car
2007 48V no run/charge issues. kind of lengthy. Electric Club Car
new batts and charger wont charge, charger works on other carts Electric Club Car
can i charge batts.individually until... Electric Club Car


All times are GMT -5. The time now is 11:59 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.