lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-25-2014, 07:47 AM   #1
Not Yet Wild
 
Join Date: Nov 2012
Posts: 19
Default 2000 Regen 2-No go!!

Rode around the other day, plugged in the charger and let it sit for a few days. Try to use it today and no forward or reverse. When I press the pedal, I hear the solenoid clicking but nothing.

2000 48v Regen DS
Toggle F/R switch
Tow/Run Switch
Pie shaped wiper speed control (cleaned contacts)

I tapped on the solenoid, but still nothing. The batteries are 6 months old and fully charged. What could it be?

Thank you!!
boozer88 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-25-2014, 04:03 PM   #2
Gone Wild
 
Join Date: Dec 2010
Posts: 458
Default Re: 2000 Regen 2-No go!!

check the power circuit (6g wires) for terminal corrosion or separation on batteries, solenoids, controller and motor.
Golfdog is online now   Reply With Quote
Unread 09-25-2014, 08:42 PM   #3
Not Yet Wild
 
Join Date: Nov 2012
Posts: 19
Default Re: 2000 Regen 2-No go!!

Thanks!! Ill check them again. I didn't see anything when I checked them earlier.
boozer88 is offline   Reply With Quote
Unread 09-27-2014, 11:38 PM   #4
Not Yet Wild
 
Join Date: Nov 2012
Posts: 19
Default Re: 2000 Regen 2-No go!!

Checked everything....couldn't see anything abnormal. Any other possibilities??
boozer88 is offline   Reply With Quote
Unread 09-29-2014, 08:01 PM   #5
Not Yet Wild
 
Join Date: Nov 2012
Posts: 19
Default Re: 2000 Regen 2-No go!!

Nothing loose or cooroded. Could it be a bad solenoid??? What would the part number be for it?
boozer88 is offline   Reply With Quote
Unread 09-30-2014, 03:13 PM   #6
Gone Wild
 
Join Date: Dec 2010
Posts: 458
Default Re: 2000 Regen 2-No go!!

Quote:
Originally Posted by boozer88 View Post
Nothing loose or cooroded. Could it be a bad solenoid??? What would the part number be for it?
If your car has one solenoid then its part #101908701. If its an earlier production with 2 solenoids then its part #101883601
Golfdog is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2000 Club Car DS Regen 48v problems Electric Club Car
2000 DS Regen 2 only 10mph Electric Club Car
2000 Club Car Regen question Extreme DC!
2000 Regen Question Electric Club Car
2000 Regen no go Electric Club Car


All times are GMT -5. The time now is 08:06 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.