lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-16-2015, 09:50 PM   #11
Gone Wild
E-Z-GO
 
Join Date: Mar 2014
Location: NE Indiana & SW Florida
Posts: 1,134
Default Re: Spawn of Satan cart won't run!

Do you have a digital volt meter?
usgicollector is online now   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-16-2015, 09:57 PM   #12
Getting Wild
 
Join Date: Sep 2013
Posts: 115
Default Re: Spawn of Satan cart won't run!

Quote:
Originally Posted by usgicollector View Post
Do you have a digital volt meter?
Yes, but I have not a clue how to check a cart since I have never done it before.
mdaddyrabbit is offline   Reply With Quote
Unread 02-17-2015, 07:41 AM   #13
Master of All Things
 
Sir Nuke's Avatar
E-Z-GO
 
Join Date: May 2013
Location: West Columbia, Texas
Posts: 9,996
Default Re: Spawn of Satan cart won't run!

Quote:
Originally Posted by mdaddyrabbit View Post
Big Cables = Battery cables?

or

electric motor cables?
ALL of them.....as that is a compete circuit. don't just look at them....verify that they are clean and tight.
Sir Nuke is offline   Reply With Quote
Unread 02-17-2015, 09:13 PM   #14
Getting Wild
 
Join Date: Sep 2013
Posts: 115
Default Re: Spawn of Satan cart won't run!

First time I have had a chance to post. Been without power for last 17 hours because of ICE. I checked all battery cables and motor cables. The box where the pedal is connected too clicks when the pedal is pressed down.
mdaddyrabbit is offline   Reply With Quote
Unread 02-18-2015, 11:02 PM   #15
Getting Wild
 
Join Date: Sep 2013
Posts: 115
Default Re: Spawn of Satan cart won't run!

Well I had some time off today because of the ice and no electric service so I loaded up the old cart and dropped it at the shop. I decided to let someone else scratch their head. If this don't work out I may go in debt.......
mdaddyrabbit is offline   Reply With Quote
Unread 02-19-2015, 10:23 AM   #16
Gone Wild
 
Kerrville78028's Avatar
 
Join Date: Jan 2015
Location: Kerrville, Texas
Posts: 162
Default Re: Spawn of Satan cart won't run!

I bet it turns out to be something simple.
Kerrville78028 is offline   Reply With Quote
Unread 02-21-2015, 03:20 PM   #17
Getting Wild
 
Join Date: Sep 2013
Posts: 115
Default Re: Spawn of Satan cart won't run!

It was the Forward/Reverse switch selector keeping cart from running.

What is wrong if you press the pedal all the way down and the cart stops but if you don't press it all the way the cart runs? The shop says I need a Cart Potentiometer/Speed Control Switch
mdaddyrabbit is offline   Reply With Quote
Unread 02-21-2015, 07:00 PM   #18
Gone Mad
E-Z-GO
 
Join Date: Oct 2009
Location: Buford, GA
Posts: 7,132
Default Re: Spawn of Satan cart won't run!

If you have a pot box, check the resistance at no throttle and WOT. They are adjustable, and yours may be going too far, which can be adjusted.
yurtle is online now   Reply With Quote
Unread 02-21-2015, 09:37 PM   #19
Getting Wild
 
Join Date: Sep 2013
Posts: 115
Default Re: Spawn of Satan cart won't run!

Quote:
Originally Posted by yurtle View Post
If you have a pot box, check the resistance at no throttle and WOT. They are adjustable, and yours may be going too far, which can be adjusted.
Thanks for the advice. Will I need to take it off to adjust?
mdaddyrabbit is offline   Reply With Quote
Unread 02-22-2015, 06:11 AM   #20
Gone Mad
E-Z-GO
 
Join Date: Oct 2009
Location: Buford, GA
Posts: 7,132
Default Re: Spawn of Satan cart won't run!

If you download the service manual from the stickies, they should have the specs - say 0 - 5000 ohms (I'm guessing) - and how to adjust it. I don't have a pot box, but have heard this comment enough to know if the resistance is too high, the controller will stop responding when you exceed this value.

As to having to remove, I don't think so, but check the manual. Other than cutting out at wide open throttle, does it accelerate normally/smoothly thru the range until it cuts out?

Also, can you check the Resistance at wide open throttle? The manual may tell where to take this measurement.
yurtle is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes



All times are GMT -5. The time now is 08:12 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.