lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-30-2015, 04:23 PM   #11
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2015
Location: Katy TX
Posts: 11
Default Re: 2005 PDS - All accesories quit working after rain storm

Quote:
Originally Posted by kgsc View Post
You say the accessories go through the key.. Couple of questions.. Do you have the standard single position key switch or the two position made for factory lights ? If you have the double switch do the other accessories start working at the first click ? If so, does the cart still work after they quit ?

If it is a double position switch and the accessories come on at the first click and the cart still works it isn't the switch..
I'll get pictures together tonight, great idea. The dc converter is wired to a fuse panel that feeds the accessofies. The pos lead and ground are cabled to batteries. Pictures will help.

It has the factory 2 position switch. And no accessories work in either position. The cart has continued to drive great, just something up with the 12v system.
culhan9 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-30-2015, 07:48 PM   #12
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2015
Location: Katy TX
Posts: 11
Default Re: 2005 PDS - All accesories quit working after rain storm

Never mind all the dust, we have some new construction in our neighborhood and its been lots of fun to riding everywhere!

Sometimes you dont realize how much something needs a bath until you take a picture of it!

Might be hard to see, but from what I can tell, everything is grounded to that back right NEG terminal. Power is fed to the DC converter via the POS terminal on the top left battery.
Attached Images
File Type: jpg 20150730_183601.jpg (175.7 KB, 0 views)
File Type: jpg 20150730_183632.jpg (173.5 KB, 0 views)
File Type: jpg 20150730_192726a.jpg (93.1 KB, 0 views)
File Type: jpg 20150730_183551.jpg (332.1 KB, 0 views)
culhan9 is offline   Reply With Quote
Unread 07-31-2015, 07:50 AM   #13
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 13,781
Default Re: 2005 PDS - All accesories quit working after rain storm

Quote:
Originally Posted by culhan9 View Post
Never mind all the dust, we have some new construction in our neighborhood and its been lots of fun to riding everywhere!

Sometimes you dont realize how much something needs a bath until you take a picture of it!

Might be hard to see, but from what I can tell, everything is grounded to that back right NEG terminal. Power is fed to the DC converter via the POS terminal on the top left battery.
As kgsc mentions earlier, it sounds like you have a grounding issue.

Your DC/DC converter is a five wire system, so the "ground" (B-) wires from all of your 12V accessories ought to be connected to the Black wire coming out of the converter rather that the main negative terminal of the battery pack.

Here is how I would connect the converter:

Input:
1. Blue wire connected to battery pack's main positive terminal.
2. Yellow wire connected to battery pack's main negative terminal.

Output:
3. Red wire connected to the +12V fuse block
4. Black wire connected to the -12V distribution block.

Remote On/Off:
5. White wire connected to switched 36V at keyswitch.
JohnnieB is offline   Reply With Quote
Unread 07-31-2015, 08:39 AM   #14
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2015
Location: Katy TX
Posts: 11
Default Re: 2005 PDS - All accesories quit working after rain storm

Thanks JohnnieB, I see what you are saying, looks like they did indeed hook up both the yellow 48/36 V GND and the black 12v GND wires from the DC converter to the NEG post on the battery. Great catch!!!

I'll get after it this weekend and post up the results.

Cheers!
culhan9 is offline   Reply With Quote
Unread 07-31-2015, 09:06 AM   #15
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 13,781
Default Re: 2005 PDS - All accesories quit working after rain storm

I bought a fuse block that also has a distribution bus for ground.

That way the +12V and -12V wires to/from everything all originate at the same place and makes it easier to troubleshoot.
JohnnieB is offline   Reply With Quote
Unread 08-01-2015, 01:35 PM   #16
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2015
Location: Katy TX
Posts: 11
Default Re: 2005 PDS - All accesories quit working after rain storm

Ok, took apart and chased all the grounds and found that the DC converter did not go to the ground post for all the accessories, thankfully. I did get it working with a new main output 12V fuse and cleaning up the 12v ground wires. Like it was first mentioned, definitely seems like a grounding gremlin. I think I should upgrade the fuse panel like you mentioned above JonnieB.

On a side note, radio worked again.... but after a quick ride to the local CVS on the cart, the speakers quit working. LOL, I felt thankful it was just the speakers not working now. More troubleshooting in my near future. :)
culhan9 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2006 ez go pds quit working Electric EZGO
2005 Precedent Suddenly quit working Electric Club Car
94 club car quit working Electric Club Car
my charger quit working Electric EZGO
lights quit working Electric EZGO


All times are GMT -5. The time now is 10:41 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.