lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-13-2015, 09:43 AM   #1
Gone Wild
 
mazdawg(Mikey)'s Avatar
E-Z-GO
 
Join Date: Oct 2010
Location: Lancaster SC
Posts: 817
Default Cart quit running while cruising

So we are down here at the beach on vacation. We had been driving the cart for most of the day off and on. Last night we were cruising the strip in ocean lakes when the cart just died. The green light wasn't on the controller. I brought my tools with me so I checked a few things. The key cylinder had continuity as well as the run/tow switch did too. Pack voltage was sitting at 49.9v. We started pushing it but got tired. We sent family to get the truck and trailer to come pick us up. It had been roughly 20mins from initial stopping time till then. I switched the cart on and it started working. I quickly drove it back to the house for the night. Any ideas what it could have been? Btw it's a 96 txt with 48v Trojans, alltrax dcx400 controller, 1/0awg wire, and a plum quick bandit motor.
mazdawg(Mikey) is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-13-2015, 09:54 AM   #2
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 63,851
Default Re: Cart quit running while cruising

No light on the control indicates no power to the controller. Power at the key or just continuity? Intermittent contact or failing pedal box micro switch would be prime suspects.
scottyb is online now   Reply With Quote
Unread 07-13-2015, 11:38 AM   #3
Gone Wild
 
kgsc's Avatar
E-Z-GO
 
Join Date: Dec 2009
Location: Aiken, SC
Posts: 6,162
Default Re: Cart quit running while cruising

Or maybe a failing reed switch..
kgsc is offline   Reply With Quote
Unread 07-13-2015, 01:47 PM   #4
Gone Wild
 
mazdawg(Mikey)'s Avatar
E-Z-GO
 
Join Date: Oct 2010
Location: Lancaster SC
Posts: 817
Default Re: Cart quit running while cruising

I was getting power to the switch on both sides as well as the run/tow switch.
mazdawg(Mikey) is offline   Reply With Quote
Unread 07-13-2015, 02:27 PM   #5
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 63,851
Default Re: Cart quit running while cruising

Quote:
Originally Posted by mazdawg(Mikey) View Post
I was getting power to the switch on both sides as well as the run/tow switch.
Power through the r/t switch?
Wait for it to quit if it's running now and check for power at controller pins #6,9,& 10. If you have power at those 3 and no LED light the controller has failed
scottyb is online now   Reply With Quote
Unread 07-13-2015, 02:52 PM   #6
Gone Wild
 
mazdawg(Mikey)'s Avatar
E-Z-GO
 
Join Date: Oct 2010
Location: Lancaster SC
Posts: 817
Default Re: Cart quit running while cruising

Quote:
Originally Posted by scottyb View Post
Power through the r/t switch?
Wait for it to quit if it's running now and check for power at controller pins #6,9,& 10. If you have power at those 3 and no LED light the controller has failed
Is that starting from left to right? Are they numbered? It's working now but if it fails again I'll check those
mazdawg(Mikey) is offline   Reply With Quote
Unread 07-13-2015, 11:57 PM   #7
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 9,724
Default Re: Cart quit running while cruising

Pin 8 is absent.
Attached Images
File Type: jpg DCX-wire-diagram2.gif.cf.jpg (31.6 KB, 0 views)
cgtech is offline   Reply With Quote
Unread 07-16-2015, 09:39 PM   #8
Gone Wild
 
mazdawg(Mikey)'s Avatar
E-Z-GO
 
Join Date: Oct 2010
Location: Lancaster SC
Posts: 817
Default Re: Cart quit running while cruising

So it quit on me again. This time the controller still has a green light on. When I press the pedal the green light flashes red and the cart moves like an inch
mazdawg(Mikey) is offline   Reply With Quote
Unread 07-16-2015, 09:47 PM   #9
Gone Wild
 
mazdawg(Mikey)'s Avatar
E-Z-GO
 
Join Date: Oct 2010
Location: Lancaster SC
Posts: 817
Default Re: Cart quit running while cruising

From alltrax's troubleshooting guide, it blinked 6 times red which indicates under voltage issue? Could I have my settings wrong? Guess I need to plug the laptop in it and see
mazdawg(Mikey) is offline   Reply With Quote
Unread 07-16-2015, 10:54 PM   #10
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 9,724
Default Re: Cart quit running while cruising

If the solenoid is clicking, but code shows "undervoltage" i would be looking at the solenoid.
cgtech is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Cart quit running Electric EZGO
Cart quit running suddenly Electric Club Car
Golf Cart suddenly quit running Electric Club Car
Cart slows down on cruising speed Gas Yamaha
1997 ezgo txt electric cart quit running need help Electric EZGO


All times are GMT -5. The time now is 11:34 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.