lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-14-2008, 01:42 PM   #1
Gone Wild
 
Join Date: Dec 2007
Location: Central Florida
Posts: 320
Default Turn signals...again

Can someone provide me with the correct way to hook up the tail lights?

There are brake lights and a turn signal - I can't figure out what the hell is going on here...

Anyone have the stock ez go wiring harness all hooked up with brake lights and signals?

I would love to know which wires are hooked to which in the back of the cart...
Blue Chip is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-14-2008, 11:59 PM   #2
prop. A$$hole's Garage
 
CC-John's Avatar
 
Join Date: Dec 2007
Location: Deep inside the Central Scrutinizer (77096)
Posts: 1,563
Default Re: Turn signals...again

The factory wire harness colors are as follows..

Driver Side:
Taillamp - Blue/White
Brake/w Turn Sig. - White
Ground - Black

Pass. Side:
Taillamp - Blue/White
Brake/w Turn Sig. - Yellow
Ground - Black

The factory light fixture wiring is as follows:
Taillamp - Black
Stop/Turn - Red
Ground - White

Most aftermarket light fixtures are as follows:
Taillamp - Brown
Stop/Turn - Red
Ground - Black

Hope this helps..
CC-John is offline   Reply With Quote
Unread 12-15-2008, 06:46 AM   #3
Gone Wild
 
Join Date: Dec 2007
Location: Central Florida
Posts: 320
Default Re: Turn signals...again

I think I have tried about every combo there is on this.... this one has me stumped.

At the current time here is what happens -

Brake lights - work fine.
Running lights - work fine

When you use the turn signal switch - the indicator light on the switch itseld lights up - it stays on steady. Nothing else happens though.

Let's say I turn the signal to indicate a left hand turn and hit the brakes - the left hand light doesn't light up at all....

HELP!!!!
Blue Chip is offline   Reply With Quote
Unread 12-15-2008, 02:39 PM   #4
Gone Wild
 
Join Date: Dec 2007
Location: Central Florida
Posts: 320
Default Re: Turn signals...again

Got it.

Wires crossed in the front of the cart.... DUH!
Blue Chip is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
ezgo turn signals update Electric EZGO
Doesn't turn over Gas Club Car
G16 don't turn off Gas Yamaha
turn signals Gas Yamaha
Turn Signals Electric Club Car


All times are GMT -5. The time now is 09:03 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.