lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-25-2008, 09:48 PM   #1
Not Yet Wild
 
pineyboy's Avatar
E-Z-GO
 
Join Date: Dec 2008
Location: TN
Posts: 33
Default Battery cable getting HOT

Hey everyone. I'm new to the forum, although I have been lurking for a few weeks. I have an 04 ezgo and one of the battery cables is getting very hot. I've cleaned and checked all of the connections. When my batteries are fully charged I get 42 volts total. Each battery is around 6.85 volts except one is 6.78 and one is 6.7 volts. My question is, do I have a bad battery, a bad cable, or could it be the motor?
pineyboy is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-25-2008, 10:01 PM   #2
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,912
Default Re: Battery cable getting HOT

Welcome to BGW.

It won't be the motor. It has to be the cable or one of the connections. The crimp could be bad. Replace the cable that is getting hot.
roady89 is offline   Reply With Quote
Unread 12-25-2008, 10:10 PM   #3
Not Yet Wild
 
pineyboy's Avatar
E-Z-GO
 
Join Date: Dec 2008
Location: TN
Posts: 33
Default Re: Battery cable getting HOT

Thanks I was hoping someone would tell me that.
pineyboy is offline   Reply With Quote
Unread 12-26-2008, 12:45 AM   #4
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,042
Default Re: Battery cable getting HOT

If 1 cable is bad..........the others may not be far behind.
scottyb is offline   Reply With Quote
Unread 12-26-2008, 02:42 PM   #5
Not Yet Wild
 
pineyboy's Avatar
E-Z-GO
 
Join Date: Dec 2008
Location: TN
Posts: 33
Default Re: Battery cable getting HOT

I replaced the one cable with 2 awg. welding cable. Problem solved. I have alot of this size cable. I think I will replace all of them now. Thanks everyone. I'm new to this and I will have alot of questions.
pineyboy is offline   Reply With Quote
Unread 12-26-2008, 06:08 PM   #6
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,042
Default Re: Battery cable getting HOT

Replace all of the cables with that wire and you will see an improvement
scottyb is offline   Reply With Quote
Unread 12-28-2008, 01:45 AM   #7
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: Battery cable getting HOT

Welcome to the forum pineyboy.....................
rusty is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Battery Cable Question Electric golf carts
Broken Battery Cable Electric EZGO
Battery Cable To Motor Electric EZGO
06 Precedent Battery cable spark. Electric Club Car
Club Car Battery Cable - Pictures Gas Club Car


All times are GMT -5. The time now is 01:04 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.