lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-29-2015, 05:34 PM   #1
Gone Wild
 
Join Date: Jul 2012
Posts: 160
Default Help! Pds dead!!

Hello and thanks in advance.

I have a ez go pds (I'm pretty sure about this it has f and r switch on dash). I put a 400 amp alltrax controller on it a couple of years ago. I left it sitting in the rain over the weekend (a lot of rain) (yes I know stupid). I got back today jumped on it. Heard a sparking/bad connection noise. I took seat off looked as I pressed pedal and saw sparks coming from the big fuse that connects to battery number 1 (or 6) in the series not sure which one it would be. I wiggled it and it felt lose

So, I cleaned up tightened it and drove it about 400 feet and I could feel it quitting. Pulled seat back off. No spark but When I pressed pedal the green light on the controller blinks really quickly as long as you hold the pedal down. Every now and then the red light will flash: 6 times usually but occasionally it is less than 6 times. The cart will try and move for a split second when the pedal is fully depressed but then quits and nothing.

Like I said it was out in the rain for several days and we got a lot of rain here in Georgia! Everything was soaked on the inside when I got on it to drive today.. PLEASE HELP!

Thanks!
georgia088 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-30-2015, 06:35 AM   #2
Gone Wild
 
JMGreco's Avatar
E-Z-GO
 
Join Date: Nov 2010
Location: Jarrettsville, MD
Posts: 206
Default Re: Help! Pds dead!!

I would start by letting everything dry out, fully charge the pack, get a reading on the pack as well as each battery. Check each connection and see what it gets you. If you are still getting the same error codes on the controller, find your manual and see what they mean. I am sure if you post what Alltrax controller you have, someone on the forum will know what the codes are if you lost the manual.
JMGreco is offline   Reply With Quote
Unread 12-30-2015, 07:03 AM   #3
Gone Wild
E-Z-GO
 
Join Date: Aug 2014
Location: fletcher,nc
Posts: 601
Default Re: Help! Pds dead!!

check your pedal box for water also...
mutant is offline   Reply With Quote
Unread 12-30-2015, 08:26 AM   #4
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 68,547
Default Re: Help! Pds dead!!

Quote:
Originally Posted by mutant View Post
check your pedal box for water also...
I agree. I've got carts that never come in out of the rain.....no problem. Sounds like you could use some cable connection maintenance too
scottyb is offline   Reply With Quote
Unread 12-30-2015, 10:36 AM   #5
Gone Wild
 
Join Date: Jul 2012
Posts: 160
Default

Well I charged over night under garage. So it should have dried out some. I took foot pedal cover off. It's not sitting in water, but I'm sure it got soaked. The cart will move slightly when you press the accelerator but then quit. I have visually checked most all connections and they look pretty good. I have not tested each battery individually or as a whole. Any ideas?


Sent from my iPhone using Tapatalk
georgia088 is offline   Reply With Quote
Unread 12-30-2015, 11:51 AM   #6
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 68,547
Default Re: Help! Pds dead!!

Get the wife's hair dryer and dry out the inside of the throttle induction coil. Hopefully that does it
scottyb is offline   Reply With Quote
Unread 12-30-2015, 12:56 PM   #7
Gone Wild
 
Join Date: Jul 2012
Posts: 160
Default

I just checked. It looks completely dry... Cart still try's to go but then quits and controller flashes red lights. Any ideas?
Thanks!


Sent from my iPhone using Tapatalk
georgia088 is offline   Reply With Quote
Unread 12-30-2015, 01:00 PM   #8
Gone Wild
 
kgsc's Avatar
E-Z-GO
 
Join Date: Dec 2009
Location: Aiken, SC
Posts: 7,299
Default Re: Help! Pds dead!!

We need a count and color on those flashes.. Also model number of that controller if possible..
kgsc is offline   Reply With Quote
Unread 12-30-2015, 01:07 PM   #9
Gone Wild
 
Join Date: Jul 2012
Posts: 160
Default

It's 3 red blinks pause 3 red blinks or 6 blinks in a row. I will get you the model number momentarily. Thanks!


Sent from my iPhone using Tapatalk
georgia088 is offline   Reply With Quote
Unread 12-30-2015, 01:12 PM   #10
Gone Wild
 
Join Date: Jul 2012
Posts: 160
Default

Alltrax model dcx400pds


Sent from my iPhone using Tapatalk
georgia088 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Batteries dead or charger dead Electric Yamaha
dead g1 Gas Yamaha
Dead cart, possible dead Solenoid Electric Club Car
48v CC dead,everythings dead Electric Club Car


All times are GMT -5. The time now is 11:32 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.