lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-10-2016, 01:54 PM   #1
Not Yet Wild
 
Join Date: Oct 2015
Posts: 4
Default 2005 EZGO TXT motor not running and running jerky

I have a 2005 EZGO TXT 36v. Recently the cart has had some issues where sometimes when I step on the gas pedal it will not respond. If I push the cart to get the wheels rolling while pressing on the pedal it will suddenly go. Even when it is going it can sometimes be jerky and act like it doesn't have full power especially when going up hills. It does the same thing in forward and reverse.

All of the batteries are fairly new having been replaced about a year and a half ago and the voltages seem normal. All of the connections to the batteries have been verified to be good and solid.

Please help with any suggestions on what could be wrong or what I need to test. I really don't want to start throwing money at parts without knowing what it could be. Thanks for your help!!
aviator77 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-10-2016, 02:49 PM   #2
Gone Wild
Yamaha
 
Join Date: May 2012
Location: Rio Verde, Az
Posts: 2,688
Default Re: 2005 EZGO TXT motor not running and running jerky

This sounds like possibly a motor that needs new brushes. Moving it makes connection. If that is the case, you want to get it serviced proto because it can take out your controller when it is doing that.
Volt_Ampere is offline   Reply With Quote
Unread 04-10-2016, 07:34 PM   #3
Gone Wild
 
timmyjane's Avatar
E-Z-GO
 
Join Date: Jul 2015
Location: Simpsonville, SC
Posts: 245
Default Re: 2005 EZGO TXT motor not running and running jerky

Could it also be the contacts in the FR switch? Maybe it needs to be tightened a little to ensure a firm connection.
timmyjane is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2010 EZGO not running/running very slowly Electric EZGO
2005 ezgo pds running slow Electric EZGO
2005 Electric EzGo wont go but motor sounds like it is running? Electric EZGO
95 medalist running jerky Electric EZGO
Club car running hesitant and Jerky Electric Club Car


All times are GMT -5. The time now is 12:15 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.