lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-26-2016, 12:36 PM   #1
Not Yet Wild
 
Join Date: Feb 2016
Posts: 10
Default 07 Ezgo Pds Help!!!

Hello,

This one has me stumped, and I will lay the information out the best that I can for some good ideas on fixing this cart.

So the cart is an 07 Ezgo PDS and batteries are new trojans installed.

The cart normally drives well, so here are the issues.

Every few times I drive it is goes pretty slow, like half speed. If I stop and turn the cart off and restart it, it works again. I can also, when it runs slow, let up on the pedal, switch the rocker switch to neutral and back to forward, hit the gas and it runs at normal speed.

The other issue is, I get in the car start driving it works well, stop for a minute at a traffic light, hit the pedal and nothing. turn the key off and back on and it drives normally. when this happens I can also switch from forward to neutral and it will work. I can also flip the tow and it works.


This is a friends cart, and I know for a fact he has replaced everything, and I do mean everything, with no change in performance.
So here is the list of things he replaced, with all new OEM parts, and I know it because he gave me all the old parts.

1- Motor
2- wiring harness
3- speed magnet
4- forward reverse switch
5-key switch
6- Its and micro
7- controller
8-solenoid
9 charging recpticle


Driving me crazy and costing him a bunch so any help would be great.
All torn open to test anything....
sboehm is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-27-2016, 10:14 PM   #2
Not Yet Wild
E-Z-GO
 
Join Date: Dec 2008
Location: Normangee,Tx
Posts: 47
Default Re: 07 Ezgo Pds Help!!!

Geno, I have a 2006 ezgo pds, that runs when it has a mind to, It may run normal for a week , then let it set maybe 5 min. no go. the cart is driving me crazy. you can never be 100 % sure it s going to run, new batteries new 4 ga. cables, new tbs harness, new run tow harness, new solenoid, resistor is in tolerance, new 350 amp controller. all connections tight, also new diode on small solenoid post.I haven't dropped motor yet, that's next any ideas or help appreciated. Geno1066.
geno1066 is offline   Reply With Quote
Unread 04-28-2016, 06:34 AM   #3
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 15,801
Default Re: 07 Ezgo Pds Help!!!

When cart is misbehaving, what is the battery pack voltage?

And what is the voltage on all the pins with highlighted wires attached?
JohnnieB is offline   Reply With Quote
Unread 05-09-2016, 10:16 AM   #4
Not Yet Wild
 
Join Date: Feb 2016
Posts: 10
Default Re: 07 Ezgo Pds Help!!!

Haha,

red wire on solenoid was on the wrong post.


Thanks for the help.

Seth
sboehm is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes



All times are GMT -5. The time now is 02:17 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.