lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-29-2016, 11:48 PM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2012
Location: NC
Posts: 44
Default Forward and Reverse Issue - 94 series

guys, I am working on bringing back to life a 94 EZGO series cart. I purchased a new F/R switch and solenoid and the cart is running, which is a plus, but i am having an issue. After installing everything, the cart ran backwards (forward in reverse and vice versa) so I traced the wires and sure enough, B and D on the switch were reversed per the wiring diagram. However, now in forward it is running half speed. So i searched and i have seen a number of posts about this but no solution that has worked for me. Currently the cart direction matches the F/R switch. However, forward is 1/2 speed. If I disconnect the orange wire it runs full speed (or seems close to it), but it isnt right. I am wondering if the notches in the new F/R switch cam are right. Everything is installed the way it was, but the MS are acting in reverse than the way they should.

So with all that said, on a stock TXT series, when the F/R switch is in forward which contacts on the F/R switch are suppose to be bridged? C/D and A/B? and reverse would be C/B and D/A? Can anyone let me know so I can figure out what the heck is going on?

Also heard on TXT the linkage can be hooked up backwards. Can someone put there TXT in Forward and take a picture of the F/R switch so i can compare and make sure the PO didnt install the rod backwards? Thanks all.

joej85a is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-30-2016, 05:56 AM   #2
Gone Wild
 
kgsc's Avatar
E-Z-GO
 
Join Date: Dec 2009
Location: Aiken, SC
Posts: 7,158
Default Re: Forward and Reverse Issue - 94 series

Shifter should be pointed up and toward your right leg when in forward. Same for the linkage. Rod should be on top.
kgsc is offline   Reply With Quote
Unread 04-30-2016, 08:24 AM   #3
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2012
Location: NC
Posts: 44
Default Re: Forward and Reverse Issue - 94 series

Ok so i went out this morning and put it in Forward and here is what is all looks like:
The lever is pointed up and towards my right leg when sitting in the driver seat. The connecting rod is on the top of the connector at the F/R switch, but it is pointed towards the passenger side of the cart when in Forward and as you can see, both MS are in indentations. What gives? Can someone verify this linkage is correct?






The ARM is pointing up here, kinda hard to tell.



Thanks All
joej85a is offline   Reply With Quote
Unread 04-30-2016, 08:35 AM   #4
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 68,345
Default Re: Forward and Reverse Issue - 94 series

Below is the install sheet I made up for F&R replacement. It shows which contacts are bridged in F and in R. Also take a look at "Important tech note" as nobody else tells you that sliding the F&R sideways is a contact adjustment. Make sure the switch cam is travelling stop to stop. If not you will burn the contacts. Looks like you may be out of adjustment. Hope this helps.
Attached Images
File Type: jpg 0.1Ezgo F&R instruc EZ575.jpg (120.5 KB, 0 views)
scottyb is offline   Reply With Quote
Unread 04-30-2016, 08:53 AM   #5
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2012
Location: NC
Posts: 44
Default Re: Forward and Reverse Issue - 94 series

Ok now I'm more confused. When my handle is in the forward position (pointing towards my leg while sitting on it) the F/R cam is bridging 4&5, 3&8. If I am reading that correctly, that should be reverse. The cam is traveling from stop to stop and can't go any further either way. This looks like a linkage problem to me. Can anyone verify it is right? Or wrong?
joej85a is offline   Reply With Quote
Unread 04-30-2016, 09:26 AM   #6
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2012
Location: NC
Posts: 44
Default Re: Forward and Reverse Issue - 94 series

So essentially, when my handle says forward, the cam, micro switches are all working as if it is reverse. Maybe I'll just let let it be with a backwards handle but that drives me crazy
joej85a is offline   Reply With Quote
Unread 04-30-2016, 09:35 AM   #7
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 68,345
Default Re: Forward and Reverse Issue - 94 series

The linkage bar "Y" may be on upside down. see below
Can you post a pic of the F&R linkage in neutral
Attached Images
File Type: jpg F&R-Exploded-View-for-print.jpg (134.7 KB, 0 views)
scottyb is offline   Reply With Quote
Unread 04-30-2016, 09:40 AM   #8
Gone Wild
E-Z-GO
 
Join Date: Dec 2013
Location: SE Louisiana
Posts: 257
Default

Quote:
Originally Posted by joej85a View Post
Ok so i went out this morning and put it in Forward and here is what is all looks like:
The lever is pointed up and towards my right leg when sitting in the driver seat. The connecting rod is on the top of the connector at the F/R switch, but it is pointed towards the passenger side of the cart when in Forward and as you can see, both MS are in indentations. What gives? Can someone verify this linkage is correct?






The ARM is pointing up here, kinda hard to tell.



Thanks All
In the second pic......can you move the linkage to the top? That should reverse the direction of operation. Only thing I can't tell is if there is enough room?

Sent from my SAMSUNG-SM-N910A using Tapatalk
270Handiman is offline   Reply With Quote
Unread 04-30-2016, 10:24 AM   #9
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2012
Location: NC
Posts: 44
Default Re: Forward and Reverse Issue - 94 series

yup that was it! it had been put on pointing at 6 oclock and needed to be pointing to 12. Thanks all!
joej85a is offline   Reply With Quote
Unread 05-01-2016, 07:16 AM   #10
Gone Wild
 
kgsc's Avatar
E-Z-GO
 
Join Date: Dec 2009
Location: Aiken, SC
Posts: 7,158
Default Re: Forward and Reverse Issue - 94 series

Is that a B8 on that battery? Are they truly that old? What numbers or on a negative terminal?

Oh and glad you figured it out and i guess I should have been clearer in my original post.
kgsc is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
99 EZGO Series.. Goes fast in reverse.. nothing in forward Electric EZGO
99' club car DS series.... reverse but no forward Electric Club Car
txt series clicking in forward and reverse Electric EZGO
G22 Forward / Reverse issue Gas Yamaha
06 series no forward but will go in reverse Electric EZGO


All times are GMT -5. The time now is 12:23 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.