lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-05-2017, 05:27 PM   #1
Not Yet Wild
 
Join Date: Jun 2016
Posts: 64
Default 1984 ezgo 36v starts slow?

Has good batterys and everything works it just when you mash on the gas it rolls really slow but eventually gets up to normal speed, what could this be?
Brandeis_ is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-08-2017, 08:31 AM   #2
Gone Wild
 
Join Date: Oct 2013
Posts: 187
Default Re: 1984 ezgo 36v starts slow?

It sounds like there could be an issue with the first or second contact on your board. The wiper has to make good contact with all of them for it to work correctly. Disconnect the battery pack and push the pedal and watch the wiper as it moves.

These things do wear out and you have to replace the board and wiper occasionally. Good luck with it.
coosa is offline   Reply With Quote
Unread 04-08-2017, 11:43 AM   #3
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 9,811
Default Re: 1984 ezgo 36v starts slow?

Well, since the moving contact should already be on the "Max Speed/all resistors bypassed" contact when pedal is "mashed", I'm skeptical of the "problems with first or second contact" idea. What we really need to know is how low your batteries droop when you do this "pedal mash"...
cgtech is offline   Reply With Quote
Unread 04-12-2017, 10:25 AM   #4
Not Yet Wild
 
Join Date: Jun 2016
Posts: 64
Default Re: 1984 ezgo 36v starts slow?

I found that on the bottom of the controller the plate was gone so there was a big hole in the controller probably got moisture and is probably about to go out , orderd another and waiting.
Brandeis_ is offline   Reply With Quote
Unread 04-14-2017, 11:35 AM   #5
Not Yet Wild
 
Join Date: Jun 2016
Posts: 64
Default Re: 1984 ezgo 36v starts slow?

I ordered a stock replacement, now it goes 10 mph the customer said it did 26, I have another controller that's stock and missing the back plate also and the one I pulled off has a way bigger capasator or whatever that may be,does that mean the controller was high performance or how can you tell
Brandeis_ is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
ezgo starts to slow? Electric EZGO
1984 DS Gas only starts in service Gas Club Car
1984 ez-go gas starts great good compression, no power Gas EZGO
91 EZgo 36volt, starts off slow then runs fine? Electric EZGO


All times are GMT -5. The time now is 09:33 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.