lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-13-2017, 02:38 PM   #11
Getting Wild
 
sltintexas's Avatar
E-Z-GO
 
Join Date: Apr 2016
Location: North Texas
Posts: 142
Default Re: 1999 EZgo TXT no power on hills

Quote:
Originally Posted by swolfbauer View Post
not sure where to find "stickies"
go here http://www.buggiesgonewild.com/electric-ezgo/

The first 20+ posts start with the word "Sticky"
sltintexas is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-13-2017, 02:38 PM   #12
Gone Wild
 
whit71's Avatar
Club Car
 
Join Date: Nov 2013
Location: North Augusta SC
Posts: 255
Default Re: 1999 EZgo TXT no power on hills

Quote:
Originally Posted by swolfbauer View Post
not sure where to find "stickies"
Click on the Electric EZ-GO forum. there will be a list of "STICKY"
whit71 is offline   Reply With Quote
Unread 04-13-2017, 03:27 PM   #13
Gone Wild
E-Z-GO
 
Join Date: Aug 2014
Location: fletcher,nc
Posts: 581
Default Re: 1999 EZgo TXT no power on hills

this is starting to look like a stickie situation......................
mutant is online now   Reply With Quote
Unread 04-13-2017, 03:49 PM   #14
Gone Wild
 
JaxPilot's Avatar
E-Z-GO
 
Join Date: Jun 2015
Location: St. Augustine, FL
Posts: 328
Default Re: 1999 EZgo TXT no power on hills

Quote:
Originally Posted by mutant View Post
this is starting to look like a stickie situation......................
C'mon, mutant, you can't take the easy ones like that!
JaxPilot is offline   Reply With Quote
Unread 04-15-2017, 01:52 PM   #15
Not Yet Wild
 
Join Date: Apr 2017
Posts: 6
Default Re: 1999 EZgo TXT no power on hills

I was told by a local DC motor shop to look at the brushes, had to motor off and measured the brush wear and they are in really good shape. Tried it out again in my back yard (very little slope) in very short time I felt the motor, controller and heat sink. They were very warm to where you could not hold your hand on them. Is this normal? or is that alone telling me something?
swolfbauer is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
1999 EZGO TXT no power to the motor Electric EZGO
1999 Ezgo slow up hills Electric EZGO
1993 EZGo lacking power up hills with new batteries Electric EZGO
'96 EZGO - slight power loss up hills Gas EZGO
1999 G16 dies on hills Gas Yamaha


All times are GMT -5. The time now is 05:00 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.