lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-21-2017, 07:16 AM   #11
Gone Wild
 
meimk's Avatar
Club Car
 
Join Date: Jun 2011
Location: Northern Indiana
Posts: 1,232
Default Re: Ezgo TXT electric lights turn signal problem.

Quote:
Originally Posted by Sir Nuke View Post
this may sound silly.....but the rear lights....are they in fact a 2 element bulb? and if so, they should have 3 wires coming out of the fixture. one for the running /blinker light/element, one for the brake light element, and one for the ground. if so.....then you have something wired incorrectly.

HOWEVER, If you only have 2 wires coming out of your rear lights fixtures....that's your problem, you have a single element bulb fixture.
He says it worked correctly in the past, so I would think the wiring is there. In my experience most of the aftermarket kits have the turn signals to the rear tied to the brake lights, not the running/tail lights. Could be an issue in the brake light switch or it's wiring into the turn signal switch. I've had several in the shop where the wires inside the turn signal switch housing have pulled/twisted/rubbed through the insulation and are touching things they shouldn't.

Last edited by meimk; 08-21-2017 at 07:18 AM.. Reason: Correction
meimk is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-21-2017, 07:35 AM   #12
Gone Wild
 
beach cart's Avatar
E-Z-GO
 
Join Date: Dec 2011
Location: Jacksonville Beach, FL
Posts: 586
Default Re: Ezgo TXT electric lights turn signal problem.

Thanks, I'll try and match that turn signal switch. It disconnects with a Molex connector on the steering shaft.

Sent from my SM-T710 using Tapatalk
beach cart is offline   Reply With Quote
Unread 08-21-2017, 12:06 PM   #13
Master of All Things
 
Sir Nuke's Avatar
E-Z-GO
 
Join Date: May 2013
Location: West Columbia, Texas
Posts: 10,726
Default Re: Ezgo TXT electric lights turn signal problem.

Quote:
Originally Posted by beach cart View Post
No rear lights have 3 wires but also are LED.

Sent from my SM-T710 using Tapatalk
well you are WRONG.....as mine do, as well as the cart I just finished....the sockets are made for dual element bulbs. like a regular single bulb set up for ANY car....or trailer.....and as I posted above, there is a wire for each element and one for the ground.

3 wire rear.jpg

see?? BLACK, WHITE, AND RED.....3 DIFFERENT WIRES.
Sir Nuke is offline   Reply With Quote
Unread 08-21-2017, 12:28 PM   #14
Gone Wild
 
ARKSoft84's Avatar
E-Z-GO
 
Join Date: Jun 2017
Location: NC
Posts: 368
Default Re: Ezgo TXT electric lights turn signal problem.

Quote:
Originally Posted by Sir Nuke View Post
well you are WRONG.....as mine do, as well as the cart I just finished....the sockets are made for dual element bulbs. like a regular single bulb set up for ANY car....or trailer.....and as I posted above, there is a wire for each element and one for the ground.

Attachment 158044

see?? BLACK, WHITE, AND RED.....3 DIFFERENT WIRES.

Wow... I think that he meant that his light has 3 wires he just didn't put the punctuation in.


This is how I read it "No, the rear lights have 3 wires and they are also LED."
ARKSoft84 is offline   Reply With Quote
Unread 08-21-2017, 05:03 PM   #15
Master of All Things
 
Sir Nuke's Avatar
E-Z-GO
 
Join Date: May 2013
Location: West Columbia, Texas
Posts: 10,726
Default Re: Ezgo TXT electric lights turn signal problem.

Quote:
Originally Posted by ARKSoft84 View Post
Wow... I think that he meant that his light has 3 wires he just didn't put the punctuation in.


This is how I read it "No, the rear lights have 3 wires and they are also LED."
well its now what he said/typed.....he said/typed "No rear lights have 3 wires but also are LED" making a statement that.....if that's not what he meant/intended to say....well I'm sorry if I came off a little gruff.....cause they way he typed it, and the way it came across is that I didn't know what I was talking about. so there ya go......in the event it was just a miscommunication...as I said....sorry if I came across a little gruff.
Sir Nuke is offline   Reply With Quote
Unread 08-21-2017, 05:07 PM   #16
Gone Wild
 
ARKSoft84's Avatar
E-Z-GO
 
Join Date: Jun 2017
Location: NC
Posts: 368
Default Re: Ezgo TXT electric lights turn signal problem.

I'm 98% certain that they do not make an LED taillight that is only 2 wire. Mass production, makes more since to do 3 wire on every single one, and then make two different wiring harnesses.
ARKSoft84 is offline   Reply With Quote
Unread 08-21-2017, 05:21 PM   #17
Gone Wild
 
beach cart's Avatar
E-Z-GO
 
Join Date: Dec 2011
Location: Jacksonville Beach, FL
Posts: 586
Default Re: Ezgo TXT electric lights turn signal problem.

It is 3 wire and Led.

Sent from my SM-T710 using Tapatalk
beach cart is offline   Reply With Quote
Unread 08-21-2017, 05:23 PM   #18
Gone Wild
 
beach cart's Avatar
E-Z-GO
 
Join Date: Dec 2011
Location: Jacksonville Beach, FL
Posts: 586
Default Re: Ezgo TXT electric lights turn signal problem.

Thanks I'll look at that

Sent from my SM-T710 using Tapatalk
beach cart is offline   Reply With Quote
Unread 08-21-2017, 05:38 PM   #19
Getting Wild
E-Z-GO
 
Join Date: Nov 2016
Location: QRO. MEX.
Posts: 100
Default Re: Ezgo TXT electric lights turn signal problem.

Quote:
Originally Posted by beach cart View Post
The rear do work with the switch on and cart running. When the 3way ezgo switch is in 3rd position lights on it happens.

Sent from my SM-T710 using Tapatalk
I may have misunderstood, but are u saying that everything works ok "with the switch on and cart running" and that the problem is only when the car is stopped and the key switch to Lights?

Why would you want turning light to flicker while stopped?


Quote:
Originally Posted by beach cart View Post
Not sure, both rear will flicker sometimes as a ground was bad. I've spent days hunting this. No bad connects, it just showed one day.

Sent from my SM-T710 using Tapatalk
Deluxe kit also has the stop pedal add-on, so the stop lights go on when braking. Is this connected properly?
Venteuri is offline   Reply With Quote
Unread 08-21-2017, 09:15 PM   #20
Gone Wild
 
beach cart's Avatar
E-Z-GO
 
Join Date: Dec 2011
Location: Jacksonville Beach, FL
Posts: 586
Default Re: Ezgo TXT electric lights turn signal problem.

I have changed no connections, all lights worked fine for months

Sent from my SM-T710 using Tapatalk
beach cart is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
adding turn signal to new LED lights Electric Club Car
Turn Signal and Brake Lights Gas EZGO
Ezgo TXT LEDBhead/tail lights with turn signal kits Electric EZGO
EZgo Electric Turn Signal Switch Problems Electric EZGO


All times are GMT -5. The time now is 09:00 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.