lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-20-2017, 06:20 PM   #1
Gone Wild
 
beach cart's Avatar
E-Z-GO
 
Join Date: Dec 2011
Location: Jacksonville Beach, FL
Posts: 586
Default Ezgo TXT electric lights turn signal problem.

I have deluxe Led light kit with turn signals. The problem is the turn signals in rear work perfect for day time driving. When the start switch is turned to lights, I have no rear flashing signals, front is fine. I have checked everything I can think of. I'm wondering if it could be the 3 position keyswitch, it doesn't make sense though. Any help or suggestions are appreciated.

Sent from my SM-T710 using Tapatalk
beach cart is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-20-2017, 06:29 PM   #2
Gone Wild
 
ARKSoft84's Avatar
E-Z-GO
 
Join Date: Jun 2017
Location: NC
Posts: 368
Default Re: Ezgo TXT electric lights turn signal problem.

Are the rear turn signals wired to the fronts?
ARKSoft84 is offline   Reply With Quote
Unread 08-20-2017, 06:45 PM   #3
Gone Wild
 
beach cart's Avatar
E-Z-GO
 
Join Date: Dec 2011
Location: Jacksonville Beach, FL
Posts: 586
Default Re: Ezgo TXT electric lights turn signal problem.

Not sure, both rear will flicker sometimes as a ground was bad. I've spent days hunting this. No bad connects, it just showed one day.

Sent from my SM-T710 using Tapatalk
beach cart is offline   Reply With Quote
Unread 08-20-2017, 06:46 PM   #4
Gone Wild
 
beach cart's Avatar
E-Z-GO
 
Join Date: Dec 2011
Location: Jacksonville Beach, FL
Posts: 586
Default Re: Ezgo TXT electric lights turn signal problem.

I thought of the turn signal arm, but still not sure.

Sent from my SM-T710 using Tapatalk
beach cart is offline   Reply With Quote
Unread 08-20-2017, 07:19 PM   #5
Gone Wild
 
ARKSoft84's Avatar
E-Z-GO
 
Join Date: Jun 2017
Location: NC
Posts: 368
Default Re: Ezgo TXT electric lights turn signal problem.

If the fronts work, id just wire the rears to the fronts.
ARKSoft84 is offline   Reply With Quote
Unread 08-20-2017, 07:27 PM   #6
Gone Wild
 
beach cart's Avatar
E-Z-GO
 
Join Date: Dec 2011
Location: Jacksonville Beach, FL
Posts: 586
Default Re: Ezgo TXT electric lights turn signal problem.

The rear do work with the switch on and cart running. When the 3way ezgo switch is in 3rd position lights on it happens.

Sent from my SM-T710 using Tapatalk
beach cart is offline   Reply With Quote
Unread 08-20-2017, 10:59 PM   #7
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 13,101
Default Re: Ezgo TXT electric lights turn signal problem.

Is the turn signal kit Ezgo stuff too? The lights evidently are (3 position key). There are some wires (already waiting for you) to be swapped at the tail lights when the turn signal kit is installed. Assuming it's Ezgo stuff...
cgtech is offline   Reply With Quote
Unread 08-21-2017, 06:47 AM   #8
Gone Wild
 
beach cart's Avatar
E-Z-GO
 
Join Date: Dec 2011
Location: Jacksonville Beach, FL
Posts: 586
Default Re: Ezgo TXT electric lights turn signal problem.

The kit is not ezgo. These lights front and rear worked right for a year or so. No problems till just one day. I've traced twice, no breaks etc. Strange they work fine with lights off.

Sent from my SM-T710 using Tapatalk
beach cart is offline   Reply With Quote
Unread 08-21-2017, 06:48 AM   #9
Master of All Things
 
Sir Nuke's Avatar
E-Z-GO
 
Join Date: May 2013
Location: West Columbia, Texas
Posts: 10,704
Default Re: Ezgo TXT electric lights turn signal problem.

this may sound silly.....but the rear lights....are they in fact a 2 element bulb? and if so, they should have 3 wires coming out of the fixture. one for the running /blinker light/element, one for the brake light element, and one for the ground. if so.....then you have something wired incorrectly.

HOWEVER, If you only have 2 wires coming out of your rear lights fixtures....that's your problem, you have a single element bulb fixture.
Sir Nuke is offline   Reply With Quote
Unread 08-21-2017, 07:13 AM   #10
Gone Wild
 
beach cart's Avatar
E-Z-GO
 
Join Date: Dec 2011
Location: Jacksonville Beach, FL
Posts: 586
Default Re: Ezgo TXT electric lights turn signal problem.

No rear lights have 3 wires but also are LED.

Sent from my SM-T710 using Tapatalk
beach cart is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
adding turn signal to new LED lights Electric Club Car
Turn Signal and Brake Lights Gas EZGO
Ezgo TXT LEDBhead/tail lights with turn signal kits Electric EZGO
EZgo Electric Turn Signal Switch Problems Electric EZGO


All times are GMT -5. The time now is 03:20 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.