lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-06-2017, 03:40 PM   #1
Gone Wild
 
yamahaguy97's Avatar
Yamaha
 
Join Date: Jan 2016
Location: FL
Posts: 1,067
Default Rxv still has issue

Hey

After I installed the new female receptacle I found out the cart won't run. Determined solenoid Is OK, and checked the fuses near the controller. Cart can be rolled easily when key is on in forward or reverse so the motor brake may be bad? I also found a small grey wire that goes under the controller and up to something under the heatsink. It was broken and I re connected it still no go. Checked the motor brake plug and I am getting pack voltage from the plug. Checked plug under the cup holder and it is in tight with no sign of damage. Any other ideas?
yamahaguy97 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-06-2017, 04:56 PM   #2
Gone Wild
E-Z-GO
 
Join Date: Oct 2015
Location: GA/NC/TN Tri-state area
Posts: 1,319
Default Re: Rxv still has issue

Quote:
Originally Posted by yamahaguy97 View Post
Hey

After I installed the new female receptacle I found out the cart won't run. Determined solenoid Is OK, and checked the fuses near the controller. Cart can be rolled easily when key is on in forward or reverse so the motor brake may be bad? I also found a small grey wire that goes under the controller and up to something under the heatsink. It was broken and I re connected it still no go. Checked the motor brake plug and I am getting pack voltage from the plug. Checked plug under the cup holder and it is in tight with no sign of damage. Any other ideas?
Check the position of your run/tow switch. It sounds like it is set to tow mode. If that does not help, check the status of your tow bypass mode jumpers. The information on proper settings should be printed on the label on the underside of the plastic cover over the controller.
BobBoyce is offline   Reply With Quote
Unread 10-06-2017, 05:25 PM   #3
Gone Wild
 
yamahaguy97's Avatar
Yamaha
 
Join Date: Jan 2016
Location: FL
Posts: 1,067
Default Re: Rxv still has issue

Lol no I definitely donít have it set in tow mode. But whatís this about tow bypass jumpers? Where is it located and what does it look like ?
yamahaguy97 is offline   Reply With Quote
Unread 10-06-2017, 06:16 PM   #4
Gone Wild
E-Z-GO
 
Join Date: Oct 2015
Location: GA/NC/TN Tri-state area
Posts: 1,319
Default Re: Rxv still has issue

Quote:
Originally Posted by yamahaguy97 View Post
Lol no I definitely don’t have it set in tow mode. But what’s this about tow bypass jumpers? Where is it located and what does it look like ?
You have to remove the plastic cover that holds the run/tow switch and turn it over. Read the label there, it will explain. The motor brake is obviously releasing, so that means it is working. That does not mean that it is good or bad. The reason it is releasing must be determined. That is why I asked you to check the bypass settings and the run/tow switch setting. If those are correct, then you must consider that the motor brake output from the controller could be faulty. There is no failure mode in the error list that would result in the motor brake releasing. All error modes result in a failure to release the motor brake. So it's not going to be a regular error mode. It would have to be a hardware failure in the controller, a wiring error, or the bypass jumpers or run/tow switch setting.
BobBoyce is offline   Reply With Quote
Unread 10-10-2017, 03:02 PM   #5
Gone Wild
 
yamahaguy97's Avatar
Yamaha
 
Join Date: Jan 2016
Location: FL
Posts: 1,067
Default Re: Rxv still has issue

Thanks for your help. It turned out the plugs were in the the wrong positions? But unfortunately, that still didn't allow the car to run. Like you said the other problem After that is either improper wiring or controller failure. Thanks again
yamahaguy97 is offline   Reply With Quote
Unread 10-11-2017, 01:51 AM   #6
Gone Wild
E-Z-GO
 
Join Date: Oct 2015
Location: GA/NC/TN Tri-state area
Posts: 1,319
Default Re: Rxv still has issue

Quote:
Originally Posted by yamahaguy97 View Post
Thanks for your help. It turned out the plugs were in the the wrong positions? But unfortunately, that still didn't allow the car to run. Like you said the other problem After that is either improper wiring or controller failure. Thanks again
Progress has been made. Now that you have fixed the bypass wiring, now it is time to run diagnostics to see where the powerup self test is failing. Do you have a shop nearby that has the correct diagnostic handset for your cart? I did not see in your first post in this thread whether it is a Danaher or Curtis controlled cart. You may have had that posted in another thread.
BobBoyce is offline   Reply With Quote
Unread 10-11-2017, 07:32 AM   #7
Gone Wild
 
yamahaguy97's Avatar
Yamaha
 
Join Date: Jan 2016
Location: FL
Posts: 1,067
Default Re: Rxv still has issue

Sorry no hand held tester for these carts. At the shop I work at we donít see the RXV that often. The controller in this cart is the grey plastic looking controller with a strange shape to it
yamahaguy97 is offline   Reply With Quote
Unread 10-11-2017, 08:23 AM   #8
Gone Wild
 
yamahaguy97's Avatar
Yamaha
 
Join Date: Jan 2016
Location: FL
Posts: 1,067
Default Re: Rxv still has issue

Itís a danaher controller
yamahaguy97 is offline   Reply With Quote
Unread 10-11-2017, 10:16 AM   #9
Gone Wild
E-Z-GO
 
Join Date: Oct 2015
Location: GA/NC/TN Tri-state area
Posts: 1,319
Default Re: Rxv still has issue

Quote:
Originally Posted by yamahaguy97 View Post
Itís a danaher controller
Where are you located at in FL?
BobBoyce is offline   Reply With Quote
Unread 10-11-2017, 04:37 PM   #10
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 9,973
Default Re: Rxv still has issue

Might have nuked the controller when you arced the wires.
cgtech is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Starting issue Club car Spark or gas issue? Gas Club Car
Speed and Throttle Issue Troubleshooting. MCOR Issue? Electric Club Car
Charging issue, but deeper issue? Gas Columbia ParCar
G16 issue Gas Yamaha
Charging Issue/ Battery Issue? Electric EZGO


All times are GMT -5. The time now is 05:59 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.